Details

    • Type: Task
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 4.2, 5.0
    • Component/s: Installer (deprecated)
    • Labels:
      None
    • Environment:
      Database: Oracle
      App Server: Weblogic
      Mobile Version: Not Applicable
      OS: RHEL
      Workdesk Version: Not Applicable

      Description

      Issue
      Customer is aware that Alfresco 4.2.2 is certified JDK 7 support. However he would like to know what is the timeline for supporting Java 8 and with which version of Alfresco? Customer requests for support of JDK 1.8/ Java 8 with Alfresco.

      Business reason
      Oracle has announced that Java SE 7 will no longer be updated publicly after April 2015. http://www.oracle.com/technetwork/java/eol-135779.html (Java SE 7 End of Public Updates Notice) so my assumption is that Alfresco will need to move to support Java 8 before then and I'm surprised it is not on the road map yet. I think a new improvement jira is required.

        Attachments

          Issue Links

            Structure

              Activity

                People

                • Assignee:
                  closedissues Closed Issues
                  Reporter:
                  sliaw Seng Liaw
                • Votes:
                  1 Vote for this issue
                  Watchers:
                  7 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved:

                    Structure Helper Panel