Details

    • ACT Numbers:

      Community

      Description

      Transient fields are not rendered. A configuration like the following only renders the model property acme:modelProperty but not the transient property acme:transientProperty.

          <config evaluator="aspect" condition="acme:Aspect">
              <forms>
                  <form>
                      <field-visibility>
                          <show id="acme:modelProperty" for-mode="view"/>
                          <show id="acme:transientProperty" for-mode="view"/>
                      </field-visibility>
                      <appearance>
                        <field id="acme:modelProperty"/>
      
                        <field id="acme:transientProperty">
                          <control template="/acme/controls/transientPropertyControl.ftl"/>
                        </field>
                      </appearance>
                  </form>
              </forms>
          </config>
      

      In Alfresco 4.2f it was possible to use transient forms like this. In Alfresco 5.0d only the acme:modelProperty is rendered.

      Expected Result

      acme:transientProperty is rendered using the configured control. It must be possible to render such a property inside a set.

      Priority

      I rate this a Critical issue because it breaks valid Share customization in a major way.

        Attachments

          Issue Links

            Structure

              Activity

                People

                • Assignee:
                  closedissues Closed Issues
                  Reporter:
                  lutz.horn Lutz Horn
                • Votes:
                  1 Vote for this issue
                  Watchers:
                  3 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved:

                    Structure Helper Panel