Uploaded image for project: 'Alfresco One Platform'
  1. Alfresco One Platform
  2. ACE-5569

Upgrade Bouncy Castle to the most recent version

    Details

    • Type: Task
    • Status: Open (View Workflow)
    • Priority: Critical
    • Resolution: Unresolved
    • Affects Version/s: 4.1, 4.2
    • Fix Version/s: None
    • Component/s: Repository
    • Labels:
      None
    • ACT Numbers:

      00354649 Premier, 00687322

      Description

      Secure LDAP access fails if Alfresco is running on SAPJVM7. See attachment alfresco-ldapsync-exception.txt for the error stack.
      SAPJVM7 is not a supported JDK but I opened this jira because the customer has a Premier contract.
      The customer has a requirement to use SAP JVM unless there is a very good reason not to.

      Currently Alfresco uses version 1.45 of Bouncy Castle Java cryptography APIs (webapps/alfresco/WEB-INF/lib/bcprov-jdk15-1.45.jar). The customer requests Alfresco to evaluate the possibility of upgrading Bouncy Castle to a version later than 1.48, preferably to the most recent version, 1.52. The customer observes the issue with versions up to 1.47. They do not observe it with version 1.48 onwards.

        Attachments

          Structure

            Activity

              People

              • Assignee:
                repositoryteam Repository Team
                Reporter:
                jsinha Jay Sinha [X] (Inactive)
              • Votes:
                0 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:

                  Structure Helper Panel