Uploaded image for project: 'Alfresco One Platform'
  1. Alfresco One Platform
  2. ACE-5616

Inconsistent responses for various <get> methods for shortcut links

    Details

    • Type: Bug
    • Status: Ready to Test (View Workflow)
    • Resolution: Not a bug
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: REST API
    • Labels:
      None

      Description

      <Create Shortcut links> feature is introduced in Alfresco 5.2 via Share UI.
      While testing related areas for shortcut link, found the following behaviour:

      Steps to reproduce:
      1. Login to Share
      2. Create a File / folder in a document library (or shared files etc)
      3. Create a shortcut link for the file / folder (Using Share UI, select the file / folder > Copy to > Create Link)
      4. Using Rest Client, execute the following api requests.

      (e.g.: http://localhost:8080/alfresco/api/-system-/public/alfresco/versions/1/nodes/<node-id-of-shortcut-link>/comments

      get /node/<node id of link>/comments return: 400: Bad request: NodeId of folder or content is expected

      get /node/<node id of link>/tags return: 200 with 0 tags in the list

      get /node/<node id of link>/ratings return: 200 with 2 ratings in the list

      Response of get /node/<node id of link>/comments is not consistent with the responses of get /node/<node id of link>/tags and get /node/<node id of link>/ratings.

      The responses are not incorrect, just incosistent. Are these expected to be consistent?

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                mbhave Meenal Bhave
              • Votes:
                0 Vote for this issue
                Watchers:
                5 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: