Uploaded image for project: 'Alfresco One Platform'
  1. Alfresco One Platform
  2. ACE-5739

error on Web Quick Start module when upgrading 5.2 Community

    Details

    • Type: Bug
    • Status: Verified (View Workflow)
    • Priority: Critical
    • Resolution: Not a bug
    • Affects Version/s: 5.2
    • Fix Version/s: None
    • Component/s: Applause (Temp)
    • Labels:
      None

      Description

      View your issue at Applause Testing Services - https://platform.applause.com/products/12989/testcycles/126637/issues/2422707
      ---- ACTION DETAILS ----

      Action Performed:
      1. Install Alfresco Community Edition (alfresco-community-installer-201612-linux-x64.bin), making sure to include/choose the installation of the Web Quick Start module (default) from the installer.

      2. Confirm the Community Edition works correctly (can log into Share, etc). Stop Community Edition

      3. Install 5.2 Enterprise build 32 (alfresco-content-services-installer-5.2.0-SNAPSHOT-linux-x64.bin)

      4. Perform the necessary upgrade steps (pointing alfresco-global.properties to the Community edition DB, and pointing dir.root and solr4 conf files to the Community Edition file paths).

      5. Start 5.2 Enterprise

      Expected Result:
      5.2 Enterprise will start successfully

      Actual Result:
      5.2 enterprise does not start.

      "Downgrading of modules is not supported.
      Module 'org_alfresco_module_wcmquickstart' version 5.2.c is currently installed and must be uninstalled before version 5.2.0-SNAPSHOT can be installed.'

      See attached 'errorLog.txt' for full alfresco.log output and stack trace

      Additional Info:
      5.2 Community Edition apply_amps.sh output:

      Module 'org.alfresco.integrations.google.docs' installed in '/opt/alfresco-community/tomcat/webapps/alfresco.war'

      • Title: Alfresco / Google Docs Integration
      • Version: 3.0.3
      • Install Date: Wed Jan 11 21:44:21 EST 2017
      • Description: The Repository side artifacts of the Alfresco / Google Docs Integration.
        Module 'alfresco-aos-module' installed in '/opt/alfresco-community/tomcat/webapps/alfresco.war'
      • Title: Alfresco Office Services Module
      • Version: 1.1.4
      • Install Date: Wed Jan 11 21:44:18 EST 2017
      • Description: Allows applications that can talk to a SharePoint server to talk to your Alfresco installation
        Module 'org_alfresco_module_wcmquickstart' installed in '/opt/alfresco-community/tomcat/webapps/alfresco.war'
      • Title: Web Quick Start
      • Version: 5.2.c
      • Install Date: Wed Jan 11 21:44:15 EST 2017
      • Description: Web Quick Start
        Module 'alfresco-share-services' installed in '/opt/alfresco-community/tomcat/webapps/alfresco.war'
      • Title: Alfresco Share Services AMP
      • Version: 5.2.0
      • Install Date: Wed Jan 11 21:44:12 EST 2017
      • Description: Module to be applied to alfresco.war, containing APIs for Alfresco Share
        Module 'org_alfresco_module_wcmquickstartshare' installed in '/opt/alfresco-community/tomcat/webapps/share.war'
      • Title: Web Quick Start Share
      • Version: 5.2.c
      • Install Date: Wed Jan 11 21:44:28 EST 2017
      • Description: Web Quick Start Share Module
        Module 'org.alfresco.integrations.share.google.docs' installed in '/opt/alfresco-community/tomcat/webapps/share.war'
      • Title: Alfresco / Google Docs Share Module
      • Version: 3.0.3
      • Install Date: Wed Jan 11 21:44:27 EST 2017
      • Description: The Share side artifacts of the Alfresco / Google Docs Integration.

      5.2 Enterprise Edition apply_amps.sh output:

      Module 'org.alfresco.integrations.google.docs' installed in '/opt/alfresco-content-services/tomcat/webapps/alfresco.war'

      • Title: Alfresco / Google Docs Integration
      • Version: 3.0.3
      • Install Date: Wed Jan 11 21:45:29 EST 2017
      • Description: The Repository side artifacts of the Alfresco / Google Docs Integration.
        Module 'org_alfresco_module_wcmquickstart' installed in '/opt/alfresco-content-services/tomcat/webapps/alfresco.war'
      • Title: Web Quick Start
      • Version: 5.2.0-SNAPSHOT
      • Install Date: Wed Jan 11 21:45:26 EST 2017
      • Description: Web Quick Start
        Module 'alfresco-aos-module' installed in '/opt/alfresco-content-services/tomcat/webapps/alfresco.war'
      • Title: Alfresco Office Services Module
      • Version: 1.1.5
      • Install Date: Wed Jan 11 21:45:21 EST 2017
      • Description: Allows applications that can talk to a SharePoint server to talk to your Alfresco installation
        Module 'alfresco-share-services' installed in '/opt/alfresco-content-services/tomcat/webapps/alfresco.war'
      • Title: Alfresco Share Services AMP
      • Version: 5.2.0
      • Install Date: Wed Jan 11 21:45:18 EST 2017
      • Description: Module to be applied to alfresco.war, containing APIs for Alfresco Share
        Module 'org.alfresco.integrations.share.google.docs' installed in '/opt/alfresco-content-services/tomcat/webapps/share.war'
      • Title: Alfresco / Google Docs Share Module
      • Version: 3.0.3
      • Install Date: Wed Jan 11 21:45:34 EST 2017
      • Description: The Share side artifacts of the Alfresco / Google Docs Integration.
        Module 'org_alfresco_module_wcmquickstartshare' installed in '/opt/alfresco-content-services/tomcat/webapps/share.war'
      • Title: Web Quick Start Share
      • Version: 5.2.0-SNAPSHOT
      • Install Date: Wed Jan 11 21:45:33 EST 2017
      • Description: Web Quick Start Share Module

      Error Code/Message:
      'Downgrading of modules is not supported.
      Module 'org_alfresco_module_wcmquickstart' version 5.2.c is currently installed and must be uninstalled before version 5.2.0-SNAPSHOT can be installed.'

      ---- ENVIRONMENT ----

      Antispyware :AVG,Antivirus:AVG,Firewall:None,Language:English ,Operating System:Windows,Web Browser:Chrome,Desktop Accessories:Webcam,Desktop Accessories:Microphone,Desktop Accessories:Speakers,Operating System Version:8.1 64-bit

      ---- UTEST PROPERTIES ----

      uTest Bug Id: 2422707

      Title: error on Web Quick Start module when upgrading 5.2 Community
      Status: Approved

      Type: Technical
      Frequency: Every Time
      Severity: High

      Product: Alfresco One (5.2 - 32)
      Test Cycle: Alfresco One - 5.2 - 32 - Upgrades

      ---- 4 Custom Fields ----

      Operating System Version (Including servicepack): RHEL 7.2

      Exact browser build version: Chrome

      Exact URL: n/a

      Your Country, Locale, Device Language: USA, English

      ---- UTEST Attachment ----

      Bug2422707_errorLog.txt : https://utest-dl.s3.amazonaws.com/8610/12989/126637/null/bugAttachment/Bug2422707_errorLog.txt?AWSAccessKeyId=AKIAJVVOIXUIFRTEEEKQ&Expires=1799740809&Signature=6JISdsu6IjSPfcFRj3g8ZfyCJNw%3D

        Attachments

          Structure

            Activity

              People

              • Assignee:
                closedissues Closed Issues
                Reporter:
                applause-admin Applause Test Integration
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Structure Helper Panel