Uploaded image for project: 'Alfresco One Platform'
  1. Alfresco One Platform
  2. ACE-5818

Alfresco fails to start on Tomcat 8.x with config files supplied in distribution zip

    Details

      Description

      View your issue at Applause Testing Services - https://platform.applause.com/products/15215/testcycles/180349/issues/3218165
      ---- ACTION DETAILS ----

      Action Performed:
      1. Install Tomcat 8.5.28 as per directions in Alfresco Docs ( https://docs.alfresco.com/5.2/tasks/configfiles-change-path.html )
      2. Deploy ACS 6.0 as per directions in https://docs.alfresco.com/5.2/tasks/alf-war-install.html
      3. Start Alfresco Server

      Expected Result:
      The server should start with no errors

      Actual Result:
      Alfresco fails to start due to an compatibility between the config files supplied in the ACS 6.0 Distribution zip and Tomcat 8

      The issue appears to be with the following files in the distribution zip
      web-server/conf/Catalina/localhost/alfresco.xml
      web-server/conf/Catalina/localhost/share.xml

      Additional Info:
      Distribution Zip used: alfresco-content-services-distribution-6.0.0-RC3.zip

      According to Tomcat 8 Migration guide ( https://tomcat.apache.org/migration-8.html#Web_application_resources ) The VirtualLoader has been replaced in Tomcat 8
      " The Aliases, VirtualLoader, VirtualDirContext, JAR resources and external repositories features that all provided a way to add resources to a web application have been replaced with a single framework rather than each being implemented separately (this was becoming increasingly difficult to maintain). The resources documentation provides details on how the new implementation may be used."

      Error Code/Message:
      First line of error: (See full log catalina.out attached)
      19-Apr-2018 03:15:32.897 SEVERE [localhost-startStop-1] org.apache.tomcat.util.digester.Digester.startElement Begin event threw exception
      java.lang.ClassNotFoundException: org.apache.catalina.loader.VirtualWebappLoader

      ---- ENVIRONMENT ----

      Language:English ,Operating System:Linux,Web Browser:Chrome,Operating System Version:Red Hat

      ---- APPLAUSE PROPERTIES ----

      Applause Issue/Bug ID: 3218165

      Title: Alfresco fails to start on Tomcat 8.x with config files supplied in distribution zip
      Status: Approved

      Type: Functional
      Frequency: Every Time
      Severity: Critical

      Product (Build): Alfresco One Service Packs (6.0)
      Test Cycle: Alfresco Content Services 6.0 - Installation

      ---- 4 Custom Fields ----

      Exact URL: N/A

      Exact browser build version: N/A

      Your Country, Locale, Device Language: N/A

      Operating System Version (Including servicepack): RHEL 7.4

      ---- APPLAUSE ATTACHMENT(S) ----

      Bug3218165_catalina.out : https://utest-dl.s3.amazonaws.com/8610/15215/180349/null/bugAttachment/Bug3218165_catalina.out?AWSAccessKeyId=AKIAJVVOIXUIFRTEEEKQ&Expires=1840177466&Signature=VJVVlkJGXlRs3ouQS4%2B5gSvTD2o%3D

      Bug3218165_tomcat env.txt : https://utest-dl.s3.amazonaws.com/8610/15215/180349/null/bugAttachment/Bug3218165_tomcat%20env.txt?AWSAccessKeyId=AKIAJVVOIXUIFRTEEEKQ&Expires=1840177466&Signature=yL7qLdWy%2B0BzutmttB%2FzS1Qwnes%3D

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                closedissues Closed Issues
                Reporter:
                applause-admin Applause Test Integration
              • Votes:
                0 Vote for this issue
                Watchers:
                9 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: