Uploaded image for project: 'Alfresco One Platform'
  1. Alfresco One Platform
  2. ACE-5846

Highlight snippets when searching with wildcard question mark are not shown in the UI

    Details

    • Bug Priority:
      Category 3
    • Regression Since:

      Description

      Preconditions:
      Login into share, create a site.

      Steps to reproduce:
      1. Into the site created, create 1 file with name="mycontent123.txt", description="mycontent123 description", title="mycontent123 title" and content="mycontent123 content".

      2. Go to faceted search and search after "??content".

      Expected result: mycontent123.txt file is shown in results. A short preview is displayed under the location of the mycontent123.txt file, with the searched term (mycontent) highlighted.
      Actual results: mycontent123.txt file is shown but only filename is highlighted.

      Also, please note that content of the file is not displayed in search results.

      This is based on FacetedSearchHighlightedTermTest1.testHighlightedSearchByWildcardQuestionMark from ShareSimplification automated tests.
      This has been manually reproduced as well.
      On Alfresco Enterprise v5.2.3 the issue is not reproduced.
      (see attached images to compare 6.0 results with 5.2.3)

        Attachments

          Activity

            People

            • Assignee:
              closedissues Closed Issues
              Reporter:
              mpopa Mihaela Popa [X] (Inactive)
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: