Uploaded image for project: 'Alfresco One Platform'
  1. Alfresco One Platform
  2. ACE-5984

Create site dialog is not closed after completing the form

    Details

    • Bug Priority:
      Category 1

      Description

      On attempt to create a site, after completing the form for the site, "Create site" dialog is not closed and remain on the screen.

      1.Login to share.
      2.Click on Sites-> Create site.
      3.Complete the form and click on "Create" button.

      Expected: "Create site" dialog is closed, user is redirected on created site page.
      ACTUAL: "Create site" dialog is not closed, site is created and end-user is confused if the site was created or not.
      NOTE: This issue replicates on Chrome and Safari, it does not replicate on Firefox browser.

      We have an error on console:

      POST http://35.181.26.219:8082/share/proxy/alfresco/api/people/admin/preferences 403
      • Network:
        GENERAL:
        Request URL: http://35.181.26.219:8082/share/proxy/alfresco/api/people/admin/preferences
        Request Method: POST
        Status Code: 403 
        Remote Address: 35.181.26.219:8082
        Referrer Policy: no-referrer-when-downgrade
        Connection: keep-alive
        Content-Length: 0
        Content-Type: text/plain
        Date: Tue, 24 Sep 2019 12:41:35 GMT
        Server: nginx/1.17.0
        X-Content-Type-Options: nosniff
        X-Frame-Options: SAMEORIGIN
        X-XSS-Protection: 1; mode=block
        Accept: */*
        Accept-Encoding: gzip, deflate
        Accept-Language: en, pt-BR, it, zh-CN, ru, zh-TW, nl, zh, nb, es, da, ja, ro-RO, ro, en-US
        Alfresco-CSRFToken: ewbJJiBGLaaq1KC8y8I1y/kJ6CutrzWtUQc/Qw+snvY=
        Connection: keep-alive
        Content-Length: 72
        Content-Type: application/json
        Cookie: JSESSIONID=2622CE522B9C31BCAF949A924CA1039E; alfLogin=1569328445; alfUsername3=admin; Alfresco-CSRFToken=ewbJJiBGLaaq1KC8y8I1y%2fkJ6CutrzWtUQc%2fQw%2bsnvY%3d; _alfTest=_alfTest
        Host: 35.181.26.219:8082
        Origin: http://35.181.26.219:8082
        Referer: http://35.181.26.219:8082/share/page/user/admin/dashboard
        User-Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_14_6) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/77.0.3865.90 Safari/537.36
        X-Requested-With: XMLHttpRequest
        {org: {alfresco: {share: {sites: {favourites: {erfgerg: true}}}}}}
        org: {alfresco: {share: {sites: {favourites: {erfgerg: true}}}}}
        alfresco: {share: {sites: {favourites: {erfgerg: true}}}}

      This is a regression issue, this issue is not replicating on ACS 6.1.1.

        Attachments

          Issue Links

            Structure

              Activity

                People

                • Assignee:
                  closedbugs Closed Bugs
                  Reporter:
                  ahodoroaba Alina Hodoroaba
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  8 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved:

                    Structure Helper Panel