Uploaded image for project: 'Service Packs and Hot Fixes'
  1. Service Packs and Hot Fixes
  2. MNT-18181

Activiti: Event sub process not triggered with start signal thrown

    Details

    • Bug Priority:
      Category 2
    • ACT Numbers:

      00626233, 00765893, 00819612, 00984324, 00988442

    • Sprint:
      Docs Sprint 18

      Description

      [Description]:
      Following the description in the docs: https://docs.alfresco.com/activiti/docs/user-guide/1.4.0/#app-bpmn-subprocess-event,
      the attempt to create a working process which fires a parallel (concurrent) subprocess when a signal is thrown
      fails because the subprocess is not being started

      [Steps to reproduce]:
      1.) Spin up an Activiti Suite v1.4.2
      2.) Log in as admin
      3.) Import sample app
      4.) Start a process of the new app
      5.) The throwing event is passed but the event subprocess is not launched.

      [Expected Behaviour]:
      Following the documentation and design elements available in the editor, it should be possible

      [Observed Behaviour]:
      Subprocess is simply not triggered by signal thrown

      [Analysis to date]:
      1.) Reproduced on Activiti v1.4.2
      2.) Please find sample app attached

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                cdenton Claire Denton
                Reporter:
                nkisa Nebil Kisa
              • Votes:
                3 Vote for this issue
                Watchers:
                6 Start watching this issue

                Dates

                • Created:
                  Updated: