Uploaded image for project: 'Alfresco'
  1. Alfresco
  2. ALF-1005

Alfresco WebDAV server cannot be mapped as network drive using default authentication settings.

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 3.2r Community
    • Fix Version/s: 4.0 Enterprise
    • Component/s: Repository, ZZ_Archive
    • Labels:
      None
    • Environment:
      3.2.0(r) build 342, both Win32/64 and *nix platforms.
    • Testcase ID:
      Hide

      Swift-101

      Show
      Swift-101
    • Resolution Time Custom Field:
      77 weeks, 4 days, 23 hours, 37 minutes, 44 seconds

      Description

      1. Deploy Alfresco with default authentication chain (alfrescoNtlm1:alfrescoNtlm)
      2.
      Under Windows 6+: Right click on "My computer" -> Map network drive - > http://host:port/alfresco/webdav
      Under earlier Windows versions: in command prompt: net use z: "http://host:port/alfresco/webdav" /user:admin

      In both cases webdav server cannot be mounted due to "The network name cannot be found" error.

      Presumably underlying problem is somwhere in Alfresco DAV server authentication logics as everything works ok with following line added to global.properties:

      ntlm.authentication.sso.enabled=true

        Attachments

          Issue Links

            Structure

              Activity

                People

                • Assignee:
                  closedbugs Closed Bugs
                  Reporter:
                  alfrescoqa Alfresco QA Team
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  1 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved:
                    Date of First Response:

                    Structure Helper Panel