Uploaded image for project: 'Alfresco'
  1. Alfresco
  2. ALF-12841

Copy/Move disalog displays error when trying to copy/move content to the moderated site where user is not invited

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 4.0 Enterprise
    • Fix Version/s: 4.2 Enterprise
    • Component/s: Share Application
    • Security Level: external (External user)
    • Labels:
      None
    • Environment:
      Alfresco EE 4.0 (build 800), all from installer.
    • Regression:
      Regression

      Description

      Steps to reproduce:

      1. Login to Share as admin;
      2. Create any moderated site 'Moderated';
      3. Create any user 'test';
      4. Login as 'test' user;
      5. Create any site and upload any document to the site;
      6. Click 'Copy' or 'Move' action for the content;
      7. Select 'Sites' and 'Moderated' site.

      Expected result:
      Document library should be displayed but dimmed.

      Actual result:
      'Could not access the Document Library' error message displayed. See attached screenshot and log file.

      AlexeyBu

        Attachments

        1. error.log
          9 kB
        2. moderated.png
          moderated.png
          25 kB
        3. screenshot-1.jpg
          screenshot-1.jpg
          24 kB

          Activity

          Hide
          dward Dave Ward [X] (Inactive) added a comment -

          Moving non-customer logged issues to Odin. Please move back if necessary.

          Show
          dward Dave Ward [X] (Inactive) added a comment - Moving non-customer logged issues to Odin. Please move back if necessary.
          Hide
          jallison Jamie Allison [X] (Inactive) added a comment -

          Screenshot taken when trying to reproduce the dug. Documents is showing and is greyed out.

          Show
          jallison Jamie Allison [X] (Inactive) added a comment - Screenshot taken when trying to reproduce the dug. Documents is showing and is greyed out.
          Hide
          jallison Jamie Allison [X] (Inactive) added a comment -

          Moderated sites do not appear in the list if the user is not a member. When the user is a member there is no error.

          Show
          jallison Jamie Allison [X] (Inactive) added a comment - Moderated sites do not appear in the list if the user is not a member. When the user is a member there is no error.
          Hide
          jallison Jamie Allison [X] (Inactive) added a comment -

          Unable to reproduce bug. The moderated site was not displayed so I added the test user to the moderated site. The moderated site was displayed with documents greyed out.

          Show
          jallison Jamie Allison [X] (Inactive) added a comment - Unable to reproduce bug. The moderated site was not displayed so I added the test user to the moderated site. The moderated site was displayed with documents greyed out.
          Hide
          alfrescoqa Alfresco QA Team added a comment -

          Successfully validated on Alfresco Enterprise v4.2.0(r53901-b227) schema 6031(OOTB); RHEL 6.3 X64
          Client: Windows 7x64, FF 23.0
          SvetlanaVi

          Show
          alfrescoqa Alfresco QA Team added a comment - Successfully validated on Alfresco Enterprise v4.2.0( r53901 -b227) schema 6031(OOTB); RHEL 6.3 X64 Client: Windows 7x64, FF 23.0 SvetlanaVi

            People

            • Assignee:
              closedissues Closed Issues
              Reporter:
              alfrescoqa Alfresco QA Team
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Date of First Response: