Uploaded image for project: 'Alfresco'
  1. Alfresco
  2. ALF-13178

Exporting spaces which rules use "link to category" action

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Duplicate
    • Affects Version/s: 3.4.d Community
    • Fix Version/s: None
    • Security Level: external (External user)
    • Labels:
      None
    • Environment:
      Alfresco Community 3.4.d
      Windows 7
    • Resolution Time Custom Field:
      3 days, 17 minutes, 40 seconds

      Description

      If you try to export through Alfresco Explorer a space having rules using the "link to category" action, the xml given specifies the noderef path as "cm:generalclassifiable/..."

      After import, you want to try to edit the rules in the imported space and face the following error :

      [code]java.lang.IllegalArgumentException: nodeRef is a mandatory parameter

      Hide Details

      java.lang.IllegalArgumentException: nodeRef is a mandatory parameter
      ...
      at $Proxy7.exists(Unknown Source)
      at org.alfresco.web.bean.repository.Repository.getNameForNode(Repository.java:209)
      at org.alfresco.web.bean.actions.handlers.LinkCategoryHandler.generateSummary(LinkCategoryHandler.java:74)
      at org.alfresco.web.bean.rules.EditRuleWizard.populateActions(EditRuleWizard.java:113)
      at org.alfresco.web.bean.rules.EditRuleWizard.init(EditRuleWizard.java:88)
      at org.alfresco.web.bean.wizard.WizardManager.setCurrentWizard(WizardManager.java:131)
      at org.alfresco.web.app.AlfrescoNavigationHandler.handleWizardOpen(AlfrescoNavigationHandler.java:690)
      at org.alfresco.web.app.AlfrescoNavigationHandler.handleNavigation(AlfrescoNavigationHandler.java:116)
      at org.apache.myfaces.application.ActionListenerImpl.processAction(ActionListenerImpl.java:82)

      I changed the xml given by putting "/cm:categoryRoot" before "/cm:generalclassifiable" and it worked for me.

      Hence, I'm not sure if it is a bug or if I'm the one who can't use Alfresco properly. Please tell me if there is only a configuration to make for this to work, because I will have to build a script otherwise.

        Attachments

          Issue Links

            Structure

              Activity

                People

                • Assignee:
                  closedissues Closed Issues
                  Reporter:
                  lyth_o Adrien Gorrell (Inactive)
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  2 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved:
                    Date of First Response:

                    Time Tracking

                    Estimated:
                    Original Estimate - 1 hour
                    1h
                    Remaining:
                    Remaining Estimate - 1 hour
                    1h
                    Logged:
                    Time Spent - Not Specified
                    Not Specified

                      Structure Helper Panel