Uploaded image for project: 'Alfresco'
  1. Alfresco
  2. ALF-1772

WCM workflow task Submitted automatically ended after some time

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Critical
    • Resolution: Fixed
    • Affects Version/s: 2.2 Enterprise
    • Fix Version/s: 4.2 Enterprise
    • Component/s: WCM
    • Labels:
      None
    • Environment:
      Alfresco 2.2 SP5 build 476 - Stack 1, RHEL 5.2, Tomcat 6.0.18, Mysql 5.1.34, JDK 5u16, Windows XP, IE 7
    • Testcase ID:

      Wcm-452

      Show
      Wcm-452

      Description

      WCM workflow task Submitted automatically ended after some time

      Steps to reproduce:
      1. Create any web project.
      2. Add any content and submit it to approver.
      3. Approve the task as approver.
      4. As initiator of the workflow goto My Alfreso page.

      Expected result: task with submitted type is present in My Tasks To Do section, content goes to Staging only after Task Done action by intiator of the workflow.
      Actual result: task with submitted type is present in My Tasks To Do section for some time and then disappears, content goes to Staging automatically.

      Please, tell us, is it behaviour "As designed" or not?
      Moreover, performing any action at Manage Task : Submitted page may cause an error in case the page is open but the task is already done.

      javax.faces.FacesException: javax.faces.el.EvaluationException: Cannot get value for expression '#

      {FileDetailsBean.previewUrl}'
      caused by:
      org.apache.jasper.JasperException: javax.faces.el.EvaluationException: Cannot get value for expression '#{FileDetailsBean.previewUrl}

      '
      caused by:
      javax.faces.el.EvaluationException: Cannot get value for expression '#

      {FileDetailsBean.previewUrl}

      '
      caused by:
      javax.faces.el.EvaluationException: Exception getting value of property previewUrl of base of type : org.alfresco.web.bean.wcm.FileDetailsBean
      caused by:
      javax.faces.el.EvaluationException: Bean: org.alfresco.web.bean.wcm.FileDetailsBean, property: previewUrl
      caused by:
      java.lang.reflect.InvocationTargetException
      caused by:
      org.alfresco.service.cmr.avm.AVMNotFoundException: Store not found.

      Olgadu

        Attachments

          Issue Links

            Activity

            mkononovich mkononovich added a comment -

            The issue also occurs on environment Windows 2003 R2 SP2 x32, JBoss 4.2.3 GA. Oracle 10g, JDK 6u11, NTLM, Vista, FF 3.5 (Alfresco 2.2 SP5 build 476 - Stack 2)

            wtaylor Will Taylor added a comment -

            Re-assigning from Ben Hagan to Mike Farman.

            alfrescoqa Alfresco QA Team added a comment -

            Closed as won't fix according to ALF-784.


              People

              • Assignee:
                closedissues Closed Issues
                Reporter:
                mkononovich mkononovich
              • Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Date of First Response: