Details

    • Type: Bug Bug
    • Status: Won't Fix
    • Priority: Unprioritized Unprioritized
    • Resolution: Unresolved
    • Affects Version/s: 4.1 Enterprise
    • Fix Version/s: None
    • Component/s: Build
    • Security Level: external (External user)
    • Labels:
      None
    • Security Severity:
      None
    • Triage:
      To Do

      Description

      We are building alfresco.war and share.war files via Alfresco Maven. When we replace latest war version files with previous version war files the error throw in logs while starting server and not able to login in Alfresco after server start.

      Module 'amp' version 1.0.1405121702 is currently installed and must be uninstalled before version 1.0.1404230738 can be installed.

      Please help us how to resolved this issue.

        Activity

        Hide
        jamil added a comment -

        can any body help me resolve issue?

        It's very urgent for me.

        Thanks,
        Jamil

        Show
        jamil added a comment - can any body help me resolve issue? It's very urgent for me. Thanks, Jamil
        Hide
        Samuel Langlois added a comment -

        Which version of Alfresco are you using? Is it really 4.1 Enterprise as stated in the ticket?
        If it is, you are probably entitled to customer support from Alfresco, which will be the best way to solve your problem quickly.
        If you are actually using Community version, or are not a supported customer, you may want to try the forums instead http://forums.alfresco.com/

        Now about the problem itself... I guess this is a security because AMPs are not supposed to ensure forward compatibility.
        You don't give much detail about the AMP. If it is your AMP, and you know it will not mess with the data, you may simply cheat and replace the version in the AMP by a more recent one - or simply rebuild it, to get a newer timestamp and thus a newer version.
        This is built with the Maven SDK, isn't it? You may want to have a look at the issue #184 which addresses a problem that you may encounter later, when this AMP is released into 1.0.

        Show
        Samuel Langlois added a comment - Which version of Alfresco are you using? Is it really 4.1 Enterprise as stated in the ticket? If it is, you are probably entitled to customer support from Alfresco, which will be the best way to solve your problem quickly. If you are actually using Community version, or are not a supported customer, you may want to try the forums instead http://forums.alfresco.com/ Now about the problem itself... I guess this is a security because AMPs are not supposed to ensure forward compatibility. You don't give much detail about the AMP. If it is your AMP, and you know it will not mess with the data, you may simply cheat and replace the version in the AMP by a more recent one - or simply rebuild it, to get a newer timestamp and thus a newer version. This is built with the Maven SDK , isn't it? You may want to have a look at the issue #184 which addresses a problem that you may encounter later, when this AMP is released into 1.0.
        Hide
        Mark Rogers added a comment - - edited

        We don't support "downgrade" of version, only upgrade. We don't consider "undo" of any patches that run in the patch service. In exceptional cases it may work, but in general there will be problems.

        Switching from Enterprise to community for example needs to be done with a schema version in advance of the enterprise version. e.g. Ent 4.1.0 to community 4.2.a

        Show
        Mark Rogers added a comment - - edited We don't support "downgrade" of version, only upgrade. We don't consider "undo" of any patches that run in the patch service. In exceptional cases it may work, but in general there will be problems. Switching from Enterprise to community for example needs to be done with a schema version in advance of the enterprise version. e.g. Ent 4.1.0 to community 4.2.a
        Hide
        jamil added a comment -

        Thanks for updates. I am using 4.1.4 enterprise trial version. it seems above statement if alfresco.war is deployed with current version and in that version some serious issue occurred and want to revert back with older version. In this case we can't revert back.

        This seems big issue with Alfresco. We need to think about this issue before buy licence version.

        Thanks once again for all your support.

        Show
        jamil added a comment - Thanks for updates. I am using 4.1.4 enterprise trial version. it seems above statement if alfresco.war is deployed with current version and in that version some serious issue occurred and want to revert back with older version. In this case we can't revert back. This seems big issue with Alfresco. We need to think about this issue before buy licence version. Thanks once again for all your support.
        Hide
        Mark Rogers added a comment -

        In general you will want to upgrade your test environment first. So its a trivial step to restore your old backup if your subsequent testing on your test environment finds some serious issue,

        I suggest that you call alfresco support if you still have concerns rather than trying to ask questions via JIRA.

        Show
        Mark Rogers added a comment - In general you will want to upgrade your test environment first. So its a trivial step to restore your old backup if your subsequent testing on your test environment finds some serious issue, I suggest that you call alfresco support if you still have concerns rather than trying to ask questions via JIRA.
        Hide
        jamil added a comment -

        Good news

        After doing long time R&D and want to share if any one else face same issue. I am able to fix this issue by changing in version value with current version in mudule.properties file.
        details are below.
        Errors in log file.
        Module 'amp' version 1.0.1406100916 is currently installed and must be uninstalled before version 1.0.1405121702 can be installed.
        at org.alfresco.error.AlfrescoRuntimeException.create(AlfrescoRuntimeException.java:46)
        at org.alfresco.repo.module.ModuleComponentHelper.startModule(ModuleComponentHelper.java:550)
        at org.alfresco.repo.module.ModuleComponentHelper.access$400(ModuleComponentHelper.java:57)
        at org.alfresco.repo.module.ModuleComponentHelper$1$1.execute(ModuleComponentHelper.java:239)
        at org.alfresco.repo.transaction.RetryingTransactionHelper.doInTransaction(RetryingTransactionHelper.java:388)
        at org.alfresco.repo.transaction.RetryingTransactionHelper.doInTransaction(RetryingTransactionHelper.java:278)
        at org.alfresco.repo.module.ModuleComponentHelper$1.doWork(ModuleComponentHelper.java:260)
        ... 54 more

        Solution
        Stop Alfresco Server

        Open module.properties file from below location and change module.version=1.0.1406100916 value to currently installed version value as error version in log file
        Alfresco\tomcat\webapps\alfresco\WEB-INF\classes\alfresco\module\amp\module.properties

        Start Alfresco server.

        Show
        jamil added a comment - Good news After doing long time R&D and want to share if any one else face same issue. I am able to fix this issue by changing in version value with current version in mudule.properties file. details are below. Errors in log file. Module 'amp' version 1.0.1406100916 is currently installed and must be uninstalled before version 1.0.1405121702 can be installed. at org.alfresco.error.AlfrescoRuntimeException.create(AlfrescoRuntimeException.java:46) at org.alfresco.repo.module.ModuleComponentHelper.startModule(ModuleComponentHelper.java:550) at org.alfresco.repo.module.ModuleComponentHelper.access$400(ModuleComponentHelper.java:57) at org.alfresco.repo.module.ModuleComponentHelper$1$1.execute(ModuleComponentHelper.java:239) at org.alfresco.repo.transaction.RetryingTransactionHelper.doInTransaction(RetryingTransactionHelper.java:388) at org.alfresco.repo.transaction.RetryingTransactionHelper.doInTransaction(RetryingTransactionHelper.java:278) at org.alfresco.repo.module.ModuleComponentHelper$1.doWork(ModuleComponentHelper.java:260) ... 54 more Solution Stop Alfresco Server Open module.properties file from below location and change module.version=1.0.1406100916 value to currently installed version value as error version in log file Alfresco\tomcat\webapps\alfresco\WEB-INF\classes\alfresco\module\amp\module.properties Start Alfresco server.

          People

          • Assignee:
            PM Unassigned
            Reporter:
            jamil
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Date of First Response: