Alfresco
  1. Alfresco
  2. ALF-21071

Installation of Alfresco Community fails on OS-X "Mavericks"

    Details

    • Type: Bug Bug
    • Status: Need Info
    • Priority: Blocker Blocker
    • Resolution: Unresolved
    • Affects Version/s: 5.0
    • Fix Version/s: None
    • Component/s: Installer
    • Security Level: external (External user)
    • Labels:
      None
    • Environment:
    • Security Severity:
      None
    • Triage:
      To Do

      Description

      When executing installation bundle alfresco-community-5.0.a-installer-osx-x64.app on my MacBookPro, execution fails with error message regarding wrong Java version.

      As can be seen from attached screenshots, the error message claims, that the installer "was packaged to run on J2SE 1.7.0_07 or later". Installed version is the most current Java runtime 1.7.0_67 - so there should be no problem. Alas - installation always fails with same error message.

      I would be grateful for any help - many thanks in advance.

        Activity

        Hide
        Mark Rogers added a comment - - edited

        Is the problem that 1.7.0_67 is smaller than 1.7.0_07 how are the numbers being compared? Numerically or alphabetically? I suspect that that 07 is the equiv of "70" or 0.7,. Something is wrong with the parsing of the version number.

        Show
        Mark Rogers added a comment - - edited Is the problem that 1.7.0_67 is smaller than 1.7.0_07 how are the numbers being compared? Numerically or alphabetically? I suspect that that 07 is the equiv of "70" or 0.7,. Something is wrong with the parsing of the version number.
        Hide
        Samuel Langlois added a comment -

        I found this forum topic which looks similar: http://community.bitnami.com/t/instal-alfresco-on-mac/11342/9
        Can you make sure that

        1. you installed the JDK, and not just the JRE
        2. the version 7 of the JDK is at the top of the list in Utilities -> Java Preferences

        Thanks for keeping us informed.

        Show
        Samuel Langlois added a comment - I found this forum topic which looks similar: http://community.bitnami.com/t/instal-alfresco-on-mac/11342/9 Can you make sure that you installed the JDK, and not just the JRE the version 7 of the JDK is at the top of the list in Utilities -> Java Preferences Thanks for keeping us informed.

          People

          • Assignee:
            Dr. Matthias H. Fröhlich
            Reporter:
            Dr. Matthias H. Fröhlich
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Date of First Response: