Uploaded image for project: 'Alfresco'
  1. Alfresco
  2. ALF-21081

Mixed dependecy versions for javax.servlet.jsp jsp-api 2.0 /2.1

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 5.0
    • Fix Version/s: 5.0
    • Component/s: Build, Web Scripts and Surf
    • Security Level: external (External user)
    • Labels:
      None
    • Security Severity:
      None
    • Triage:
      To Do

      Description

      There is a mixed of versions for dependency for
      javax.servlet jsp-api, sometimes it is version 2.0, sometimes version 2.1.
      There is also a mix of groupId used, javax.servlet I think only is used for 2.0, later versions use javax.servlet.jsp.

      See attached file for a listing where jsp-api is used.

        Activity

        Hide
        slanglois Samuel Langlois added a comment -

        Thanks for your report Peter!

        This is now fixed in HEAD (commit r82632), where the dependency of jsp-api is defined in the top-level pom, so that it is the same for everyone.
        The same was done for servlet-api, {{jstl} and a few others, which were not consistent either.

        Show
        slanglois Samuel Langlois added a comment - Thanks for your report Peter! This is now fixed in HEAD (commit r82632 ), where the dependency of jsp-api is defined in the top-level pom, so that it is the same for everyone. The same was done for servlet-api , {{jstl} and a few others, which were not consistent either.

          People

          • Assignee:
            closedissues Closed Issues
            Reporter:
            loftux Peter Löfgren
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:
              Date of First Response: