Uploaded image for project: 'Alfresco'
  1. Alfresco
  2. ALF-21120

Alfresco community 5.0.a - missing files in alfresco.war from Custom Install

    Details

    • Resolution Time Custom Field:
      12 weeks, 5 days, 7 hours, 10 minutes, 49 seconds

      Description

      I downloaded Alfresco Community 5.0.a (Custom Install) from the official link:

      https://process.alfresco.com/ccdl/?file=release/community/5.0.a-build-00023/alfresco-community-5.0.a.zip

      I extracted firstly the zip file and later also alfresco.war and share.war to /opt/tomcat-<version>/webapps/alfresco and /opt/tomcat-<version>/webapps/share.

      I found the file alfresco-global.properties.sample in the zip file and customized it.

      However, I'm not able to configure the application as in Alfresco 4.2.x or in a similar way, even if the documentation for Alfresco 5.0 (http://docs.alfresco.com/community/concepts/welcome-infocenter_community.html) references the same files. The files (or whole subdirectory structures) are simply missing in alfresco.war and the configuration directives from the documentation aren't located in another files neither.

      To be more specific:

      • the file servers subsystem configuration is missing: alfresco/WEB-INF/classes/alfresco/subsystems/fileServers, I tried to create the file alfresco/WEB-INF/classes/alfresco/subsystems/fileServers/default/file-servers.properties and configure the FTP (change port) and CIFS server (disable), without success... no change... But the documentation mentions this file and the same/similar attributes as in 4.2.x, for instance FTP: http://docs.alfresco.com/community/concepts/fileserv-ftp-intro.html

      To be more concise:

      • no alfresco/WEB-INF/classes/alfresco/repository.properties file exists
      • no alfresco/WEB-INF/classes/alfresco/subsystems/thirdparty/default/imagemagick-transform.properties
      • no alfresco/WEB-INF/classes/alfresco/subsystems/thirdparty/default/swf-transform.properties
      • no alfresco/WEB-INF/classes/alfresco/subsystems/OOoDirect/default/openoffice-transform.properties
      • no alfresco/WEB-INF/classes/alfresco/subsystems/Synchronization/default/default-synchronization.properties
      • no alfresco/WEB-INF/classes/alfresco/authority-services-context.xml (we need to set alfresco administrators group)

      Furthermore, the connection to LDAP server doesn't work (cannot login). The configuration is in alfresco-global.properties is attached. The error from catalina.out after LDAP login as well.

      Is Alfresco 5.0.a an official release prepared for production use?

        Attachments

          Issue Links

            Structure

              Activity

                People

                • Assignee:
                  closedissues Closed Issues
                  Reporter:
                  lukas.baxa Lukas Baxa
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  5 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved:
                    Date of First Response:

                    Structure Helper Panel