Uploaded image for project: 'Enterprise 3.x'
  1. Enterprise 3.x
  2. ETHREEOH-43

Lucene date range queries broken by recent LuceneQueryParser update

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Critical
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 3.0
    • Component/s: None
    • Security Level: external (External user)
    • Labels:
      None
    • Environment:
      OS X, MySQL

      Description

      The "Recently modified documents" dashlet and DocList filter was seen to not be working today. Further investigation reveals that rolling back LuceneQueryParser.java to r10611 (just before the merge from V2.9) gets them working again.

      The Lucene query is:
      +PATH:"/app:company_home/st:sites/cm:site1/cm:documentLibrary//*" +@cm\:modified:[2008\-8\-26T00\:00\:00 TO 2008\-9\-2T23\:59\:59] -ASPECT:"{http://www.alfresco.org/model/content/1.0}workingcopy" -TYPE:"{http://www.alfresco.org/model/content/1.0}thumbnail" -TYPE:"{http://www.alfresco.org/model/forum/1.0}post"

      Has the date format changed?

        Attachments

          Activity

          Hide
          pholmeshiggin Paul Holmes-Higgin added a comment -
          Andy - can you help Mike?
          Show
          pholmeshiggin Paul Holmes-Higgin added a comment - Andy - can you help Mike?
          Hide
          kroast Kevin Roast added a comment -
          Fixed by Andy for 3.0labs B
          Show
          kroast Kevin Roast added a comment - Fixed by Andy for 3.0labs B
          Hide
          srigby Steve Rigby added a comment -
          For retest
          Show
          srigby Steve Rigby added a comment - For retest
          Hide
          mkononovich mkononovich added a comment -
          Search using date ranges gives positive results.
          Fix validated on Alfresco 3.0 Enterprise build 119 using Windows 2003 R2, MS SQL Server 2005, Tomcat 6.0.18, JDK 6u7 x32, NTLM Auth
          Show
          mkononovich mkononovich added a comment - Search using date ranges gives positive results. Fix validated on Alfresco 3.0 Enterprise build 119 using Windows 2003 R2, MS SQL Server 2005, Tomcat 6.0.18, JDK 6u7 x32, NTLM Auth

            People

            • Assignee:
              closedbugs Closed Bugs
              Reporter:
              mhatfield Mike Hatfield
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: