Uploaded image for project: 'Service Packs and Hot Fixes'
  1. Service Packs and Hot Fixes
  2. MNT-13340

Cannot deploy AOS (ROOT.war and _vti_bin.war) on JBOSS

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Resolution: Fixed
    • Affects Version/s: 5.0.N
    • Fix Version/s: 5.0.2
    • Component/s: Installer
    • Labels:
    • Environment:
      Alfresco 5.0.1 (r93905-b65), Jboss 6.2 redhat 6.5

      Description

      used comment

      1. Used put ROOT.war and _vti_bin.war on ear
      2. edit ./META-INF/application.xml
        <!DOCTYPE application PUBLIC "-//Sun Microsystems, Inc.//DTD J2EE Application 1.3//EN" "http://java.sun.com/dtd/application_1_3.dtd">
        
        <application>
           <display-name>Alfresco</display-name>
           <module>
             <web>
                 <web-uri>alfresco.war</web-uri>
                 <context-root>/alfresco</context-root>
             </web>
           </module>
           <module>
             <web>
                 <web-uri>share.war</web-uri>
                 <context-root>/share</context-root>
             </web>
           </module>
           <module>
             <web>
                 <web-uri>ROOT.war</web-uri>
                 <context-root>/</context-root>
             </web>
           </module>
           <module>
             <web>
                 <web-uri>_vti_bin.war</web-uri>
                 <context-root>/_vti_bin</context-root>
             </web>
           </module>
        </application>
      3. edit ./META-INF/jboss-deployment-structure.xm
        <?xml version="1.0" encoding="UTF-8"?>
        
        <jboss-deployment-structure>
            <sub-deployment name="alfresco.war">
                <dependencies>
                    <module name="org.alfresco.configuration" />
                    <module name="org.apache.xalan" />
                </dependencies>
            </sub-deployment>
            <sub-deployment name="share.war">
                <dependencies>
                    <module name="org.alfresco.configuration" />
                </dependencies>
            </sub-deployment>
            <sub-deployment name="ROOT.war" >
               <dependencies>
                   <module name="org.alfresco.configuration" />
               </dependencies>
            </sub-deployment>
            <sub-deployment name="_vti_bin.war">
                  <dependencies>
                     <module name="org.alfresco.configuration" />
                  </dependencies>
            </sub-deployment>
        </jboss-deployment-structure>
        
      4. deploy ear on Jboss, see docs step 14
      5. start Alfresco on Jbooss

      Expected Result:

      Alfresco is started with AOS

      Actaual Result:

      AOS is not deployed

      ESC[0mESC[31m09:46:59,337 ERROR [org.jboss.msc.service.fail] (MSC service thread 1-1) MSC000001: Failed to start service jboss.web.deployment.default-host./: org.jboss.msc.
      service.StartException in service jboss.web.deployment.default-host./: Failed to start service
              at org.jboss.msc.service.ServiceControllerImpl$StartTask.run(ServiceControllerImpl.java:1767) [jboss-msc-1.0.4.GA-redhat-1.jar:1.0.4.GA-redhat-1]
              at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142) [rt.jar:1.8.0_31]
              at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617) [rt.jar:1.8.0_31]
              at java.lang.Thread.run(Thread.java:745) [rt.jar:1.8.0_31]
      Caused by: java.lang.IllegalArgumentException: JBWEB000250: Child container with name  already exists
              at org.apache.catalina.core.ContainerBase.addChildInternal(ContainerBase.java:794)
              at org.apache.catalina.core.ContainerBase.addChild(ContainerBase.java:785)
              at org.apache.catalina.core.StandardHost.addChild(StandardHost.java:353)
              at org.jboss.as.web.deployment.WebContextInjector.inject(WebContextInjector.java:62)
              at org.jboss.as.web.deployment.WebContextInjector.inject(WebContextInjector.java:38)
              at org.jboss.msc.inject.CastingInjector.inject(CastingInjector.java:55) [jboss-msc-1.0.4.GA-redhat-1.jar:1.0.4.GA-redhat-1]
              at org.jboss.msc.service.ServiceControllerImpl.doInject(ServiceControllerImpl.java:1549) [jboss-msc-1.0.4.GA-redhat-1.jar:1.0.4.GA-redhat-1]
              at org.jboss.msc.service.ServiceControllerImpl.access$1900(ServiceControllerImpl.java:49) [jboss-msc-1.0.4.GA-redhat-1.jar:1.0.4.GA-redhat-1]
              at org.jboss.msc.service.ServiceControllerImpl$StartTask.performInjections(ServiceControllerImpl.java:1780) [jboss-msc-1.0.4.GA-redhat-1.jar:1.0.4.GA-redhat-1]
              at org.jboss.msc.service.ServiceControllerImpl$StartTask.run(ServiceControllerImpl.java:1741) [jboss-msc-1.0.4.GA-redhat-1.jar:1.0.4.GA-redhat-1]
              ... 3 more
      
      ESC[0mESC[31m09:46:59,359 ERROR [org.apache.catalina.core.ContainerBase.[jboss.web].[default-host].[/_vti_bin]] (ServerService Thread Pool -- 289) JBWEB000285: Error config
      uring application listener of class com.sun.faces.config.ConfigureListener: java.lang.ClassNotFoundException: com.sun.faces.config.ConfigureListener from [Module "deploymen
      t.alfresco-enterprise-5.0.1-SNAPSHOT.ear._vti_bin.war:main" from Service Module Loader]
              at org.jboss.modules.ModuleClassLoader.findClass(ModuleClassLoader.java:197) [jboss-modules.jar:1.3.0.Final-redhat-2]
              at org.jboss.modules.ConcurrentClassLoader.performLoadClassUnchecked(ConcurrentClassLoader.java:443) [jboss-modules.jar:1.3.0.Final-redhat-2]
              at org.jboss.modules.ConcurrentClassLoader.performLoadClassChecked(ConcurrentClassLoader.java:431) [jboss-modules.jar:1.3.0.Final-redhat-2]
              at org.jboss.modules.ConcurrentClassLoader.performLoadClass(ConcurrentClassLoader.java:373) [jboss-modules.jar:1.3.0.Final-redhat-2]
              at org.jboss.modules.ConcurrentClassLoader.loadClass(ConcurrentClassLoader.java:118) [jboss-modules.jar:1.3.0.Final-redhat-2]
              at org.jboss.as.web.deployment.WebInjectionContainer.newInstance(WebInjectionContainer.java:74) [jboss-as-web-7.3.0.Final-redhat-14.jar:7.3.0.Final-redhat-14]
              at org.apache.catalina.core.StandardContext.contextListenerStart(StandardContext.java:3294) [jbossweb-7.2.2.Final-redhat-1.jar:7.2.2.Final-redhat-1]
              at org.apache.catalina.core.StandardContext.start(StandardContext.java:3777) [jbossweb-7.2.2.Final-redhat-1.jar:7.2.2.Final-redhat-1]
              at org.jboss.as.web.deployment.WebDeploymentService.doStart(WebDeploymentService.java:156) [jboss-as-web-7.3.0.Final-redhat-14.jar:7.3.0.Final-redhat-14]
              at org.jboss.as.web.deployment.WebDeploymentService.access$000(WebDeploymentService.java:60) [jboss-as-web-7.3.0.Final-redhat-14.jar:7.3.0.Final-redhat-14]
              at org.jboss.as.web.deployment.WebDeploymentService$1.run(WebDeploymentService.java:93) [jboss-as-web-7.3.0.Final-redhat-14.jar:7.3.0.Final-redhat-14]
              at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511) [rt.jar:1.8.0_31]
              at java.util.concurrent.FutureTask.run(FutureTask.java:266) [rt.jar:1.8.0_31]
              at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142) [rt.jar:1.8.0_31]
              at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617) [rt.jar:1.8.0_31]
              at java.lang.Thread.run(Thread.java:745) [rt.jar:1.8.0_31]
              at org.jboss.threads.JBossThread.run(JBossThread.java:122)
      
      ESC[0mESC[31m09:46:59,368 ERROR [org.apache.catalina.core.ContainerBase.[jboss.web].[default-host].[/_vti_bin]] (ServerService Thread Pool -- 289) JBWEB000286: Skipped installing application listeners due to previous error(s)
      ESC[0mESC[31m09:46:59,368 ERROR [org.apache.catalina.core] (ServerService Thread Pool -- 289) JBWEB001103: Error detected during context /_vti_bin start, will stop it
      ESC[0mESC[31m09:46:59,368 ERROR [org.jboss.msc.service.fail] (ServerService Thread Pool -- 289) MSC000001: Failed to start service jboss.web.deployment.default-host./_vti_bin: org.jboss.msc.service.StartException in service jboss.web.deployment.default-host./_vti_bin: org.jboss.msc.service.StartException in anonymous service: JBAS018040: Failed to start context
              at org.jboss.as.web.deployment.WebDeploymentService$1.run(WebDeploymentService.java:96)
              at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511) [rt.jar:1.8.0_31]
              at java.util.concurrent.FutureTask.run(FutureTask.java:266) [rt.jar:1.8.0_31]
              at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142) [rt.jar:1.8.0_31]
              at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617) [rt.jar:1.8.0_31]
              at java.lang.Thread.run(Thread.java:745) [rt.jar:1.8.0_31]
              at org.jboss.threads.JBossThread.run(JBossThread.java:122)
      Caused by: org.jboss.msc.service.StartException in anonymous service: JBAS018040: Failed to start context
              at org.jboss.as.web.deployment.WebDeploymentService.doStart(WebDeploymentService.java:161)
              at org.jboss.as.web.deployment.WebDeploymentService.access$000(WebDeploymentService.java:60)
              at org.jboss.as.web.deployment.WebDeploymentService$1.run(WebDeploymentService.java:93)
              ... 6 more
      

      AndreiMa

        Attachments

          Structure

            Activity

              People

              • Assignee:
                closedbugs Closed Bugs
                Reporter:
                alfrescoqa Alfresco QA Team
              • Votes:
                0 Vote for this issue
                Watchers:
                5 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Time Tracking

                  Estimated:
                  Original Estimate - Not Specified
                  Not Specified
                  Remaining:
                  Remaining Estimate - 0 minutes
                  0m
                  Logged:
                  Time Spent - 2 days, 4 hours, 30 minutes
                  2d 4h 30m

                    Structure Helper Panel