Uploaded image for project: 'Service Packs and Hot Fixes'
  1. Service Packs and Hot Fixes
  2. MNT-13944

The SSO bypass login page is not working when external authentication is enabled

    Details

      Description

      It is impossible to login to Share via the SSO bypass login page (page?pt=login) when external authentication is enabled.

      [Steps to reproduce]

      1- Enable external authentication on a vanilla 5.0.1 environment
      2- Go to http://server:port/share/page?pt=login
      3- Log in

      [Expected behaviour]

      You get logged in and see the dashboard.

      [Observed behaviour]

      The URL displayed in the address bar is the dashboard URL, but you still see the login form.

      [Analysis to date]

      Using a client debugger (e.g FireBug), we can see that the elements of the dashboard are called. Though, the login form is still being displayed (see attached screen_capture_001.jpg).

      The issue is not reproduced on 5.0.0.9

        Attachments

          Issue Links

            Structure

              Activity

                People

                • Assignee:
                  closedbugs Closed Bugs
                  Reporter:
                  jbruinaud Julien Bruinaud [X] (Inactive)
                • Votes:
                  2 Vote for this issue
                  Watchers:
                  10 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved:

                    Time Tracking

                    Estimated:
                    Original Estimate - Not Specified
                    Not Specified
                    Remaining:
                    Remaining Estimate - 0 minutes
                    0m
                    Logged:
                    Time Spent - 3 days, 2 hours
                    3d 2h

                      Structure Helper Panel