Uploaded image for project: 'Service Packs and Hot Fixes'
  1. Service Packs and Hot Fixes
  2. MNT-14408

Potential data corruption in Apache POI library

    Details

      Description

      A bug has been found in Apache POI (all versions) that causes a data corruption if the input file hass less than 4 (OOXML 8) bytes.

      This bug has been fixed by Alfresco and reported to Apache:
      https://bz.apache.org/bugzilla/show_bug.cgi?id=58156

      We maintain our own fork of the apache POI library that contains patches for bugs that did not yet made it into an official Apache POI release. The current version of this patch is: 3.10.1-20140922-alfresco-patched and can be found together with its sources in Nexus.

      We need to create an updated version of this file and change the maven dependancies. The patch is attached to the Apache bug repoprt and this JIRA ticket.

        Attachments

          Structure

            Activity

              People

              • Assignee:
                closedbugs Closed Bugs (Inactive)
                Reporter:
                skopf Stefan Kopf
              • Votes:
                0 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Time Tracking

                  Estimated:
                  Original Estimate - Not Specified
                  Not Specified
                  Remaining:
                  Remaining Estimate - 0 minutes
                  0m
                  Logged:
                  Time Spent - 6 hours, 10 minutes
                  6h 10m

                    Structure Helper Panel