Service Packs and Hot Fixes
  1. Service Packs and Hot Fixes
  2. MNT-1688

Issues with third party authentication (siteminder) and flash uploader

    Details

    • Type: Service Pack Request Service Pack Request
    • Status: Closed Closed (View Workflow)
    • Priority: Critical Critical
    • Resolution: Duplicate
    • Affects Version/s: 3.2.2
    • Fix Version/s: 3.4.5
    • Component/s: Installer
    • Labels:
      None
    • ACT Numbers:

      31469

      Description

      Flash uploader does not work with reverse proxies where 3rd party authentication is implemented
      Alfresco 3.2.2.11.
      Our setup is;

      • alfresco 3.2.2.11 running on Tomcat
      • apache frontend performing reverse proxy for backend Tomcat
      • Siteminder authentication implemented at the apache frontend

      We've found that Share's Flash uploader does not forward any session cookies on the upload traffic as documented by Yahoo. http://developer.yahoo.com/yui/uploader/
      We do see that the code surrounding the Flash uploader in Share appends the URL with the JSESSIONID so that Tomcat/Alfresco authentication can be passed.
      But since no other session cookies are being passed in the upload traffic, the upload fails on scenarios like ours where there is a frontend reverse proxy with 3rd party authentication (Siteminder) as Siteminder session cookies are not being passed.
      Is there a method to modify the Flash uploader scripts so that it passes specific session cookies on the upload traffic?

        Issue Links

          Activity

          Monica Basandrai added a comment -

          Retest with build 328

          Alfresco QA Team added a comment -

          Closed as duplicate of ALF-1078


            People

            • Assignee:
              Closed Issues
              Reporter:
              cturner
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: