Uploaded image for project: 'Service Packs and Hot Fixes'
  1. Service Packs and Hot Fixes
  2. MNT-18232

Display value field shows Unicode reference for non-english characters

    Details

    • Bug Priority:
      Category 3
    • ACT Numbers:

      00876041, 00942516

      Description

      Summary
      Display value field shows Unicode characters for non-english characters (e.g. Chinese) in field labels.

      Steps to reproduce

      1. Via App Designer create a simple process (start event -> user task -> end event)
      2. Create a form for the start event
      3. Drop 'Text' field in the form then edit the text field and modify the label to a Chinese label
      4. Click 'Override ID'
      5. Modify ID to 'label1' and save form
      6. Add another form to the user task and add a 'Display value' field
      7. Edit the display value field and inspect the available field options to display

      Current Behavior
      Display value field shows unicode characters for the field label value

      Expected Behavior
      The label should be displayed properly in Chinese.

      Supporting evidence

      • Reproduced with latest APS 1.6.2 release
      • Attached the video and my test process to demo the issue.
      • Japanese label has the same problem

        Attachments

          Issue Links

            Structure

              Activity

                People

                • Assignee:
                  dgruber Doug Gruber
                  Reporter:
                  lwang Lei Wang [X] (Inactive)
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  8 Start watching this issue

                  Dates

                  • Created:
                    Updated:

                    Structure Helper Panel