Service Packs and Hot Fixes
  1. Service Packs and Hot Fixes
  2. MNT-2031

Saving large Word (mac 2011) document via CIFS fails in Mac OS X Lion

    Details

    • Type: Service Pack Request Service Pack Request
    • Status: Closed Closed (View Workflow)
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: 3.4.8, 4.0
    • Fix Version/s: 4.0.2
    • Component/s: CIFS
    • Labels:
      None
    • ACT Numbers:

      41368

      Description

      This is really easy to reproduce:

      1. Run the latest Alfresco 3.4 HEAD or 4.0 with CIFS enabled.

      2. Mount CIFS in Mac OS X Lion.

      3. Open a large Word file from a local Mac directory, say your Desktop (make sure the document is at least 4 MB), save it (File -> Save As) to a directory in the repository via CIFS, say User Home.

      Expected result: Document saved successfully into the Alfresco repository.

      Actual result: It failed with one of the two error messages below (also attached as screenshots).

      Message 1. The disk is full trying to write to Alfresco. Free some space on this drive, or save the document on another disk.
      Message 2. There is an unrecoverable disk error on file Word Work File D_1.tmp. The disk you're working on has a media problem that prevents Word from using it.

        Issue Links

          Activity

          Mark Rogers added a comment -

          Attached "Big Doc Mac - In use".

          Which is a drag and drop of a 5 MB word file into Alfresco. Error message in finder is "The operation can't be conpleted because the item "Hello I am a big documen" is in use.

          There are no corresponding errors in alfresco.log.

          Mark Rogers added a comment -

          Gary - could you take a look at the attached wire-shark.

          Jordi Anguela added a comment -

          Hi Mark,

          I just wanted to clarify something before this ticket is marked as Fixed: in your last comment you talk about drag&drop a file directly into Alfresco and getting the famous "file in use".

          Is this the way this ticket is being tested?

          The aim of this ticket is to open a big Word document and Save it to the repository via CIFS.

          Mark Rogers added a comment -

          I was distracted by a similar looking drag and drop problem. (Actually If the truth be told I couldn't figure out how to get my nice new shiny instance of Mac Word 2011 to present the option to save to CIFS! 8-$) Anyway Craig pointed out the error of my ways above and I got some help on driving Lion and split the drag and drop issue off.

          Please validate the issue as described - which is Word Mac 2011 Save As from Mac OS X Lion.

          Jordi Anguela added a comment -

          Hello Mark, this is embarrassing, but we forgive you because it was Easter. However, now a is good moment to resurrect and face this issue.

          Jokes apart, we validate that the issue is what Craig has detailed in the description of this ticket. It is proven that you cannot safe big Word documents into CIFS using Mac Lion OS. And this is a serious showstopper for us.
          If you have any doubts, please contact Craig (our TAM).

          Regards,
          Jordi

          Craig Tan added a comment -

          This is still happening to Enterprise 4.0, revision 35952, when saving a large Word file into folders with or without rules. Please let me know if you'd like me to send you the Word file that I am using to test this.

          Mark Rogers added a comment -

          According to SVN, Build 35952 is from HEAD. It is not Enterprise 4.0.2.

          Next step is for QA to validate.

          Alfresco QA Team added a comment -

          The issue is not reproduced on Alfresco Enterprise v4.0.2 b911
          Mac OS X Lion, MS Office 2011 for Mac
          OlgaPal


            People

            • Assignee:
              Closed Bugs
              Reporter:
              Craig Tan
            • Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: