Service Packs and Hot Fixes
  1. Service Packs and Hot Fixes
  2. MNT-2063

Audit - Content starting with numbers cannot be previewed with show_audit.ftl

    Details

    • Type: Service Pack Request Service Pack Request
    • Status: Closed Closed (View Workflow)
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 3.4.6
    • Fix Version/s: 4.0.1
    • Component/s: Auditing
    • Labels:
      None
    • Environment:
      Alfresco 3.4.6, Windows 2008 Server, Mysql 5, Tomcat 6, JDK 6
    • ACT Numbers:

      38132

      Description

      Steps to reproduce:

      1. Enable auditing on a 3.4.6 instance and start the system;
      2. Pick a file whose name doesn't contain number.
      3. Show the file in preview and select show_audit.ftl: works fine (expected)
      4. Edit the file name and add 1 in front:

      Expected result:
      Audit info are displayed

      Observed:
      Audit info are displayed only for the file whose name does not contain numbers

      The above applies to both content and spaces.

      See attachments.

        Issue Links

          Activity

          Fabrizio Corsaro added a comment -

          Maybe linked to ALF-12009 ?

          Andrew Hunt added a comment -

          Yep - encoding initial numbers is part of ISO9075 as suggested in ALF-12009

          Alfresco QA Team added a comment -

          The issue is reproduced on Alfresco Enterprise 4.0.0 (792), Tomcat, PostgreSQL, Java (all installer deployed)
          Client: Windows XP, Windows 7,FF 9.0.1

          DariaMi

          Alfresco QA Team added a comment - - edited

          The issue is also actual for Alfresco Enterprise v4.0.0 (800); QALAB Stack 3 - Windows Server 2008 R2 x64, MS SQL Server 2008 R2, net.sourceforge.jtds.jdbc.Driver jtds-1.2.5.jar, Tomcat 6.0.29 as a windows service, JDK 2 u27 X64, JAAS + Kerberos; Client: IE8, Windows 7 SP1 x64
          ChristinaSh

          EDIT: The same behavior is actual for folders.

          Alan Davis added a comment - - edited

          Issue is fixed by code from ALF-12009 which has been merged to 4.0.1

          Note: Due to the change of name the audit record will only contain the audit entry for the new name. The MOVE.

          Alfresco QA Team added a comment -

          Successfully validated against environment Alfresco Enterprise v4.0.1 build 830, Tomcat, PostgreSQL, Java (all installer deployed), Win7x64, FF11.0.

          OlgaPal


            People

            • Assignee:
              Closed Bugs
              Reporter:
              Fabrizio Corsaro
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: