Details

    • Type: Service Pack Request Service Pack Request
    • Status: Closed Closed (View Workflow)
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: 3.4.5
    • Fix Version/s: 4.0.2
    • Component/s: WCM
    • Labels:
      None
    • ACT Numbers:

      3307 28156

      Description

      Renaming WCM folders causes the web form content to break, forcing users to remove and recreate to associate to Web Form (due to stale path name)

      The metadata for web form assets seems to hardcode avm paths instead of some Node ID, it doesn't matter if it's the same node or a different node: if the path changes, the web form assets break (point to stale locations).

      Note: This is not the web form output generation path failing due to the folder rename, but editing WCM assets with stale path references in metadata

      To recreate:
      1. Create Web Project
      2. Create folder in Web Project
      3. Create simple XSD
      4. Generate Web Form content in new folder
      5. Rename folder
      6. Attempt to Edit web form in newly named folder

        Activity

        dward added a comment -

        You shouldn't put the logic into the JSF client. It should go in a policy. The first task will probably be to get org.alfresco.repo.avm.AVMNodeService.moveNode() to actually fire a policy on the rename.

        Dafydd James added a comment -

        Can this please be scheduled for a fix? We badly need the ability to be able to rename web forms.

        Alfresco QA Team added a comment -

        The issue is not reproduced on Alfresco Enterprise v4.0.2 build 911, Tomcat, PostgreSQL, Java (all installer deployed), Win7x64, FF11.0
        TatianaK


          People

          • Assignee:
            Closed Bugs
            Reporter:
            Chris Dixon
          • Votes:
            2 Vote for this issue
            Watchers:
            5 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Time Tracking

              Estimated:
              Original Estimate - 0 minutes
              0m
              Remaining:
              Remaining Estimate - 0 minutes
              0m
              Logged:
              Time Spent - 3 weeks, 3 days, 6 hours, 30 minutes
              3w 3d 6h 30m