Service Packs and Hot Fixes
  1. Service Packs and Hot Fixes
  2. MNT-3810

Ubuntu installer with all options selected: scriptnode api checkin throws exception

    Details

    • Type: Bug Bug
    • Status: Closed Closed (View Workflow)
    • Priority: Critical Critical
    • Resolution: Cannot Reproduce
    • Affects Version/s: 3.4
    • Fix Version/s: 3.3.5, 3.4
    • Component/s: Repository
    • Labels:
      None
    • Environment:
      uncustomized installation of alfresco 3.4.a comunity

      Description

      I can't run the cookbook example for checkin/checkout

      var doc = userhome.createFile("checkmeout.txt");
      doc.addAspect("cm:versionable");
      doc.content = "original text";

      // check it out and update content on the working copy
      var workingCopy = doc.checkout();
      workingCopy.content = "updated text 1";

      // check it in
      doc = workingCopy.checkin();

      during checkin I get a javascript exception
      org.alfresco.error.AlfrescoRuntimeException: 09270052
      failed to write property deltas

        Activity

        Matteo Grolla added a comment -

        I did a fresh install from tomcat bundle and everything works, it's not blocker anymore.

        The problematic installation was made using the installer and adding about every additional module. Doing checkin/checkout from explorer was ok but doing it through the scriptnode api was not.

        All installations are mode on ubuntu linux 10.10

        Dmitry Vaserin added a comment - - edited

        Can't reproduce using Ubuntu 10.10 and following Alfresco installers:
        1) Enterprise 3.3.3 (205) schema 4016
        2) Enterprise 3.4.0 (b 376) schema 4111
        3) Community 3.4.0 (a 3169) schema 4111
        My steps:
        1. Install Alfresco using installer with all modules.
        2. Start Alfresco.
        3. Create script from issue description.
        4. Click DataDictionary -> Details -> Run Action.
        5. Select Execute script and specify script that was created before.
        6. Click finish.
        My result:
        Document with name "checkmeout.txt" is created in Company Home.
        Document content is "updated text 1".
        There are no errors in UI and logs.

        If this steps are not correct or if any additional steps are required, add them to comments please.

        Steve Rigby added a comment -

        For retest in 3.4 enterprise b114 or later

        Alfresco QA Team added a comment -

        Couldn't reproduce against 3.4.0 (RC1 114)

        Alfresco QA Team added a comment -

        Need to be validated on 3.3.5

        Alfresco QA Team added a comment -

        Could not reproduce against 3.3.5 (379)


          People

          • Assignee:
            Closed Issues
            Reporter:
            Matteo Grolla
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Time Tracking

              Estimated:
              Original Estimate - Not Specified
              Not Specified
              Remaining:
              Remaining Estimate - 0 minutes
              0m
              Logged:
              Time Spent - 3 hours, 30 minutes
              3h 30m