Service Packs and Hot Fixes
  1. Service Packs and Hot Fixes
  2. MNT-388

Links: Delete Link button in Selected Items menu is available for Consumer, Contributor and Collaborator

    Details

    • Type: Service Pack Request Service Pack Request
    • Status: Closed Closed (View Workflow)
    • Priority: Blocker Blocker
    • Resolution: Fixed
    • Affects Version/s: 3.4.3
    • Fix Version/s: 4.1.2
    • Component/s: Links (Share)
    • Labels:
      None
    • Environment:
      QALAB Stack 2 Windows Server 2003 SP2 x32, PostgreSQL 9.0.2, postgresql-9.0-801.jdbc4.jar, JBoss 5.1.0.EAP, JDK 6 u22 x64, NTLM
      Client: IE 9.0.x, Windows Vista / FF 5.0, WinXP x32
    • Escalated:
      Yes
    • ACT Numbers:

      51668

    • Testcase ID:

      Sanity-222, Sanity-223

      Show
      Sanity-222, Sanity-223

      Description

      Steps to reproduce:

      1. Log on the Share as admin user;
      2. Create any Test site;
      2. Create and invite any TestUser to the Test site with the Consumer, Contributor or Collaborator role;
      3. Create any TestLink in the Test site;
      4. Log on as TestUser;
      5. Select TestLink;
      7. Click Selected Items to activate drop-down menu

      Actual result:
      Delete button in Selected Items menu is present (please, see the attached screen shot). If I confirm deletion, friendly notification "Permission to delete is denied" will be displayed.

      Expected result:
      Delete button should not be present cause Consumer, Contributor and Collaborator are not able to delete links, that are not created by themselves.

      ChristinaSh

        Activity

        Alfresco QA Team added a comment -

        The issue is reproduced on Alfresco 4.1.1 b16, Suse 11.1 x64, DB2 v9.7.0.4 com.ibm.db2.jcc.DB2Driver db2jcc4.jar, WebSphere App Server Fix Pack v7.0.0.21, Java™ SDK ​​​1.6.0 SR9 FP2 for V7.0, AD LDAP client: Windows XP, IE7.
        MarinaN

        Kevin Roast added a comment -

        Merged in rev 42154

        dward added a comment -

        Needs merging to HEAD

        Alfresco QA Team added a comment -

        The issue is reproduced on Alfresco Enterprise v4.1.2 build 301, Tomcat, PostgreSQL, Java (all installer deployed), Win7x64, ff 16.0.1

        Steps to reproduce:

        1. Log on the Share as admin user;
        2. Create any Test site;
        2. Create and invite any TestUser to the Test site with the Contributor or Collaborator role;
        3. Create any TestLink in the Test site;
        4. Log on as TestUser;
        5. Select TestLink;
        7. Click Selected Items to activate drop-down menu
        Result: Delete button is not present (expected)
        8. Create any link(TestLink2) by TestUser
        9. Select TestLink2
        10. Click Selected Items to activate drop-down menu
        Result: Delete button is present (expected), but is not correctlly isplayed(please, refer to the attachment)
        11. Select TestLink
        12. Click Selected Items to activate drop-down menu
        Result: Delete button is present
        Exp. Result: as TestLink is created by another user TestUser should not be able to delete it

        TatianaK
        TatianaK

        Alfresco QA Team added a comment -

        The issue is not reproduced on Alfresco Enterprise v4.1.2 build 325, Tomcat, PostgreSQL, Java (all installer deployed), Win7x64, ff 16.0.1
        TatianaK


          People

          • Assignee:
            Closed Bugs
            Reporter:
            Alfresco QA Team
          • Votes:
            0 Vote for this issue
            Watchers:
            7 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Time Tracking

              Estimated:
              Original Estimate - 0 minutes
              0m
              Remaining:
              Remaining Estimate - 0 minutes
              0m
              Logged:
              Time Spent - 1 week
              1w