Service Packs and Hot Fixes
  1. Service Packs and Hot Fixes
  2. MNT-4327

Error when invoking webservices via SSL repository location url

    Details

    • Type: Bug Bug
    • Status: Closed Closed (View Workflow)
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 3.2
    • Fix Version/s: 3.3.3, 3.4
    • Component/s: Repository
    • Labels:
      None
    • Environment:
      Alfresco 3.2 release, Centos 5.3.

      Description

      Based on post http://forums.alfresco.com/en/viewtopic.php?f=27&t=21740&p=71525

      Invoking ContentUtils.putContent when using the following url to reach the repository (via tomcat SSL port):

      repository.location=https://dmsprod1:8443/alfresco/api

      produces the following error:

      Using endpoint https://dmsprod1:8443/alfresco/api
      Error writing content to repository server
      java.lang.RuntimeException: Error writing content to repository server
      at org.alfresco.webservice.util.ContentUtils.putContent(ContentUtils.java:276)
      at org.alfresco.webservice.util.ContentUtils.putContent(ContentUtils.java:148)
      at lu.invik.bi.print2file.Uploader.create(Uploader.java:124)
      at lu.invik.bi.print2file.ArcParser.main(ArcParser.java:59)
      Caused by: java.net.SocketException: Connection reset
      at java.net.SocketOutputStream.socketWrite(SocketOutputStream.java:96)
      at java.net.SocketOutputStream.write(SocketOutputStream.java:115)
      at java.io.DataOutputStream.writeBytes(DataOutputStream.java:259)
      at org.alfresco.webservice.util.ContentUtils.putContent(ContentUtils.java:212)
      ... 3 more
      java.lang.Exception: RuntimeException exception
      at lu.invik.bi.print2file.Uploader.create(Uploader.java:300)
      at lu.invik.bi.print2file.ArcParser.main(ArcParser.java:59)
      Caused by: java.lang.RuntimeException: Error writing content to
      repository server
      at org.alfresco.webservice.util.ContentUtils.putContent(ContentUtils.java:276)
      at org.alfresco.webservice.util.ContentUtils.putContent(ContentUtils.java:148)
      at lu.invik.bi.print2file.Uploader.create(Uploader.java:124)
      ... 1 more
      Caused by: java.net.SocketException: Connection reset
      at java.net.SocketOutputStream.socketWrite(SocketOutputStream.java:96)
      at java.net.SocketOutputStream.write(SocketOutputStream.java:115)RuntimeException
      exception
      at java.io.DataOutputStream.writeBytes(DataOutputStream.java:259)
      at org.alfresco.webservice.util.ContentUtils.putContent(ContentUtils.java:212)
      ... 3 more

      Error might come from the fact that the class is using java.net.Socket, which doesn't support SSL. There would need to be a modification to use java.net.ssl.SSLSocket when attempting to use an SSL url.

      I haven't pushed it any further, but the issue might arise in other classes as well?

      Thank you.
      fred

        Activity

        dward added a comment -

        For retest on V3.3.3 build 182

        Alfresco QA Team added a comment -

        Validated against 3.3.3.194

        dward added a comment -

        For retest in 3.4b

        Steve Rigby added a comment -

        For retest in 3.4.b build 3185 or later

        Alfresco QA Team added a comment -

        Validated against 3.4.3195


          People

          • Assignee:
            Closed Bugs
            Reporter:
            Fred Blaise
          • Votes:
            1 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: