Service Packs and Hot Fixes
  1. Service Packs and Hot Fixes
  2. MNT-439

CheckInOut.exe: CIFS Save of a (Working Copy) breaks Lock on original node and therefore can not check in

    Details

    • Type: Service Pack Request Service Pack Request
    • Status: Closed Closed (View Workflow)
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: 3.2 R
    • Fix Version/s: 3.3.2, 3.3
    • Component/s: JLAN
    • Labels:
      None
    • Environment:
      Alfresco 3.2R Ent, mysql, winxp, tomcat
    • Escalated:
      Yes
    • ACT Numbers:

      17361

      Description

      • Drag Word Doc to CheckIn/Out.exe action to check out document
      • Refresh Windows Explorer to see *(Working Copy).doc
      • Double Click Working Copy to open in word
      • Make an edit and save (CTRL + S or Word menu save)
      • Refresh windows explorer and you'll notice the icon on the original is gone.
      • Check in /alfresco and you'll notice all indications of Working Copy is a checkedout node, and the lock icon on original node is gone
      • In Windows Explorer, try to drag to checkIN/Out.exe and you'll notice it Checks Out the working copy.

      This worked in 3.2E.

        Issue Links

          Activity

          dward added a comment -

          Due for 3.2 SP1, freeze date 29th March.

          Gary Spencer added a comment -

          The problem is not in the CheckInOut desktop action but is due to the way MS Office saves it's documents by renaming the original (locked) document, creating a new file and then deleting the original version of the document.

          Gary Spencer added a comment -

          Fixed via r19759

          dward added a comment -

          Needs checking in on HEAD.

          Gary Spencer added a comment -

          Fixed via r19784

          Steve Rigby added a comment -

          For retest in 3.3E build 27

          Alfresco QA Team added a comment -

          Successfully validated against Alfresco EE v3.3.0 beta 34, RHEL 5.1 x64, Tomcat 6.0.18, Mysql 5.1.35, JDK 6u16 x64, WindowsXP, FF3.6

          Alfresco QA Team added a comment -

          Successfully validated against Alfresco 3.3.2 b 138 , RHEL 5.1 x64, Tomcat 6.0.26, Mysql 5.1.39, JDK 6u18 x64, Alfresco + OpenLDAP, Windows XP, FF 3


            People

            • Assignee:
              Closed Bugs
              Reporter:
              Scott Ashcraft
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: