Uploaded image for project: 'Service Packs and Hot Fixes'
  1. Service Packs and Hot Fixes
  2. MNT-4538

DocLib: IE: ''workingCopy.googleDocUrl' is null or not an object' script error occurs on a Document Library page after XAM Archive aspect is added

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Critical
    • Resolution: Fixed
    • Affects Version/s: 4.0.1
    • Fix Version/s: 4.0.1
    • Labels:
      None
    • Environment:
      Alfresco Enterprise v4.0.0 (b802, b830); Windows 7 SP1 x64, PostgreSQL, Tomcat, Java 6 (all deployed from win64 installer); Client: IE8+IE9

      Description

      Steps to reproduce (for Windows Server):

      1. SDK XAM and SDK VIA are downloaded for your server's operating system from https://developer-content.emc.com/downloads/centera/download.htm (I used Centera_SDK_VIM1.0p3_WinDev8.tgz and Centera_SDK_XAM1.0p3_WinDev8.tgz) and unpacked to any folder, e.g. c:\centera
      2. *.pea files are downloaded from https://community.emc.com/docs/DOC-1038 (here - c4armtesting.pea) and copied to the XAM and VIM SDK directory, e.g. to c:\centera
      3. Add the following environment variables at the Alfresco server (System variables and User variables):

      PATH=c:\centera\lib64
      XAM_VIM_PATH=c:\centera\lib64

      4. Install fresh Alfresco;
      5. Install alfresco-xamconnector.amp module to Alfresco;
      6. To the alfresco-global.properties add the following text:

      xam.xri=snia-xam://centera_vim!168.159.214.33?C:/centera/c4armtesting.pea
      xam.archive.retentionPeriodDays=1

      7. Verify that XAM Server that is being used is working using shXAM.jar tool from the latest version of XAM Developer's Pack (https://community.emc.com/docs/DOC-2542):

      • run shXAM.jar;
      • enter: connect snia-xam://centera_vim!168.159.214.33?C:/centera/c4armtesting.pea
        Connection should be established successfully.
        8. Edit alfresco/web-extension/share-config-custom.xml file with the attached one;
        9. Start Alfresco server;
        10. Log on the Share as admin user;
        11. Create any site;
        12. Create any content test.txt in the site's Document Library;
        13. Add 'XAM Archive' aspect to the created test.txt file;
        14. Open the Document Library.

      Expected result: Document Library page should be opened without any error. A list of existing files and folder should be displayed.

      Actual result: Script error occurs. A list of existing files and folder is not displayed. Please, verify the attached screen shot.

      Webpage error details

      User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; WOW64; Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; InfoPath.3)
      Timestamp: Mon, 12 Mar 2012 11:10:23 UTC

      Message: 'workingCopy.googleDocUrl' is null or not an object
      Line: 1
      Char: 22578
      Code: 0
      URI: http://127.0.0.1:8080/share/res/components/documentlibrary/documentlist-min.js

      ChristinaSh

      1. share-config-custom.xml
        1 kB
        Alfresco QA Team
      1. document-library-page.png
        113 kB
      2. script-error.png
        36 kB

        Issue Links

          Activity

          alfrescoqa Alfresco QA Team created issue -
          alfrescoqa Alfresco QA Team made changes -
          Field Original Value New Value
          Attachment document-library-page.png [ 29734 ]
          Attachment script-error.png [ 29735 ]
          akovalchuk akovalchuk made changes -
          Status New [ 10001 ] Open [ 1 ]
          Fix Version/s 4.0.1 [ 11020 ]
          akovalchuk akovalchuk made changes -
          Resource External [ 10060 ]
          Assignee UI Team Unassigned [ uiteam ] Investigation Queue [ investigation ]
          Status Open [ 1 ] Investigate [ 10004 ]
          Priority Major [ 3 ] Critical [ 2 ]
          alfrescoqa Alfresco QA Team made changes -
          Description Steps to reproduce (for Windows Server):

          1. SDK XAM and SDK VIA are downloaded for your server's operating system from https://developer-content.emc.com/downloads/centera/download.htm (I used Centera_SDK_VIM1.0p3_WinDev8.tgz and Centera_SDK_XAM1.0p3_WinDev8.tgz) and unpacked to any folder, e.g. c:\centera
          2. *.pea files are downloaded from https://community.emc.com/docs/DOC-1038 (here - c2armtesting.pea) and copied to the XAM and VIM SDK directory, e.g. to c:\centera
          3. Add the following environment variables at the Alfresco server (System variables and User variables):

          PATH=c:\centera\lib64
          XAM_VIM_PATH=c:\centera\lib64

          4. Install fresh Alfresco;
          5. Install alfresco-xamconnector.amp module to Alfresco;
          6. To the alfresco-global.properties add the following text:

          xam.xri=snia-xam://centera_vim!168.159.214.33?C:/centera/c4armtesting.pea
          xam.archive.retentionPeriodDays=1

          7. Verify that XAM Server that is being used is working using shXAM.jar tool from the latest version of XAM Developer's Pack (https://community.emc.com/docs/DOC-2542):
            - run shXAM.jar;
            - enter: connect snia-xam://centera_vim!168.159.214.33?C:/centera/c4armtesting.pea
          Connection should be established successfully.
          8. Edit alfresco/web-extension/share-config-custom.xml file with the attached one;
          9. Start Alfresco server;
          10. Log on the Share as admin user;
          11. Create any site;
          12. Create any content test.txt in the site's Document Library;
          13. Add 'XAM Archive' aspect to the created test.txt file;
          14. Open the Document Library.

          Expected result: Document Library page should be opened without any error. A list of existing files and folder should be displayed.

          Actual result: Script error occurs. A list of existing files and folder is not displayed. Please, verify the attached screen shot.

          Webpage error details

          User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; WOW64; Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; InfoPath.3)
          Timestamp: Mon, 12 Mar 2012 11:10:23 UTC

          Message: 'workingCopy.googleDocUrl' is null or not an object
          Line: 1
          Char: 22578
          Code: 0
          URI: http://127.0.0.1:8080/share/res/components/documentlibrary/documentlist-min.js


          ChristinaSh
          Steps to reproduce (for Windows Server):

          1. SDK XAM and SDK VIA are downloaded for your server's operating system from https://developer-content.emc.com/downloads/centera/download.htm (I used Centera_SDK_VIM1.0p3_WinDev8.tgz and Centera_SDK_XAM1.0p3_WinDev8.tgz) and unpacked to any folder, e.g. c:\centera
          2. *.pea files are downloaded from https://community.emc.com/docs/DOC-1038 (here - c4armtesting.pea) and copied to the XAM and VIM SDK directory, e.g. to c:\centera
          3. Add the following environment variables at the Alfresco server (System variables and User variables):

          PATH=c:\centera\lib64
          XAM_VIM_PATH=c:\centera\lib64

          4. Install fresh Alfresco;
          5. Install alfresco-xamconnector.amp module to Alfresco;
          6. To the alfresco-global.properties add the following text:

          xam.xri=snia-xam://centera_vim!168.159.214.33?C:/centera/c4armtesting.pea
          xam.archive.retentionPeriodDays=1

          7. Verify that XAM Server that is being used is working using shXAM.jar tool from the latest version of XAM Developer's Pack (https://community.emc.com/docs/DOC-2542):
            - run shXAM.jar;
            - enter: connect snia-xam://centera_vim!168.159.214.33?C:/centera/c4armtesting.pea
          Connection should be established successfully.
          8. Edit alfresco/web-extension/share-config-custom.xml file with the attached one;
          9. Start Alfresco server;
          10. Log on the Share as admin user;
          11. Create any site;
          12. Create any content test.txt in the site's Document Library;
          13. Add 'XAM Archive' aspect to the created test.txt file;
          14. Open the Document Library.

          Expected result: Document Library page should be opened without any error. A list of existing files and folder should be displayed.

          Actual result: Script error occurs. A list of existing files and folder is not displayed. Please, verify the attached screen shot.

          Webpage error details

          User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; WOW64; Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; InfoPath.3)
          Timestamp: Mon, 12 Mar 2012 11:10:23 UTC

          Message: 'workingCopy.googleDocUrl' is null or not an object
          Line: 1
          Char: 22578
          Code: 0
          URI: http://127.0.0.1:8080/share/res/components/documentlibrary/documentlist-min.js


          ChristinaSh
          amalinovsky Alex Malinovsky made changes -
          Status Investigate [ 10004 ] Investigating [ 10006 ]
          Assignee Investigation Queue [ investigation ] Alex Malinovsky [ amalinovsky ]
          alfrescoqa Alfresco QA Team made changes -
          Attachment share-config-custom.xml [ 29761 ]
          amalinovsky Alex Malinovsky made changes -
          Remaining Estimate 0 minutes [ 0 ]
          Time Spent 4 hours [ 14400 ]
          Worklog Id 22916 [ 22916 ]
          akovalchuk akovalchuk made changes -
          Date_Investigated 14/Mar/12 [ 2012-03-14 ]
          Status Investigating [ 10006 ] Investigated [ 10008 ]
          Assignee Alex Malinovsky [ amalinovsky ] Investigation Queue [ investigation ]
          akovalchuk akovalchuk made changes -
          Assignee Investigation Queue [ investigation ] UI Team Unassigned [ uiteam ]
          kroast Kevin Roast made changes -
          Assignee UI Team Unassigned [ uiteam ] Kevin Roast [ kroast ]
          kroast Kevin Roast made changes -
          Link This issue is related to by ALF-13117 [ ALF-13117 ]
          kroast Kevin Roast made changes -
          Status Investigated [ 10008 ] Resolved [ 5 ]
          Assignee Kevin Roast [ kroast ] QA Backlog Unassigned [ qabacklog ]
          Resolution Fixed [ 1 ]
          rmanthena Ravi Manthena made changes -
          Assignee QA Backlog Unassigned [ qabacklog ] Alfresco QA Team [ alfrescoqa ]
          alfrescoqa Alfresco QA Team added a comment -

          The issue is not reproduced on Alfresco Enterprise v4.0.1 (b864); Windows 7 SP1 x64, PostgreSQL, Tomcat, Java 6 (all installer deployed); Client: Windows 7 SP 1 x64, IE8.
          ChristinaSh

          alfrescoqa Alfresco QA Team made changes -
          Status Resolved [ 5 ] Closed [ 6 ]
          Assignee Closed Bugs [ closedbugs ] Closed Issues [ closedissues ]
          adavis Alan Davis made changes -
          Status Closed [ 6 ] Editable Closed [ 10061 ]
          adavis Alan Davis made changes -
          Assignee Closed Issues [ closedissues ] Closed Bugs [ closedbugs ]
          adavis Alan Davis made changes -
          Project Alfresco [ 10281 ] Service Packs and Hot Fixes [ 11350 ]
          Key ALF-13273 MNT-4538
          Workflow Alfjira_II_PM [ 140571 ] Service Packs and Hot Fixes [ 176332 ]
          Resource External [ 10060 ]
          Fix Version/s 4.0.1 [ 12749 ]
          Fix Version/s 4.0.1 [ 11020 ]
          Status Transition Date 26/Mar/12 1:22 PM [ 2012-03-26T13:22+0100 ]
          Affects Version/s 4.0.1 [ 12749 ]
          Affects Version/s 4.0.1 [ 11020 ]
          Rank (Obsolete) 60990000000
          Date_Investigated 14/Mar/12 [ 2012-03-14 ]
          Component/s Document Library [ 12289 ]
          Component/s Repository [ 12313 ]
          Component/s Repository [ 10594 ]
          Component/s Document Library [ 10740 ]
          adavis Alan Davis made changes -
          Status Editable Closed [ 10061 ] Closed [ 6 ]
          adavis Alan Davis made changes -
          Workflow Service Packs and Hot Fixes [ 176332 ] Service Packs and Hot Fixes - rm EC [ 184742 ]
          adavis Alan Davis made changes -
          Workflow Service Packs and Hot Fixes - rm EC [ 184742 ] Service Packs and Hot Fixes [ 192033 ]
          Transition Time In Source Status Execution Times Last Executer Last Execution Date
          New New Open Open
          39m 31s 1 akovalchuk 12-Mar-12 12:43 PM
          Open Open Investigate Investigate
          20s 1 akovalchuk 12-Mar-12 12:44 PM
          Investigate Investigate Investigating Investigating
          1d 18h 54m 1 Alex Malinovsky 14-Mar-12 07:39 AM
          Investigating Investigating Investigated Investigated
          1d 1h 38m 1 akovalchuk 15-Mar-12 09:17 AM
          Investigated Investigated Resolved Resolved
          1h 44m 1 Kevin Roast 15-Mar-12 11:02 AM
          Resolved Resolved Closed Closed
          11d 1h 20m 1 Alfresco QA Team 26-Mar-12 01:22 PM
          Closed Closed Removed Status Removed Status
          357d 3h 56m 1 Alan Davis 18-Mar-13 04:19 PM
          Removed Status Removed Status Closed Closed
          19h 33m 1 Alan Davis 19-Mar-13 11:52 AM

            People

            • Assignee:
              closedbugs Closed Bugs
              Reporter:
              alfrescoqa Alfresco QA Team
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Time Tracking

                Estimated:
                Original Estimate - Not Specified
                Not Specified
                Remaining:
                Remaining Estimate - 0 minutes
                0m
                Logged:
                Time Spent - 4 hours
                4h