Uploaded image for project: 'Service Packs and Hot Fixes'
  1. Service Packs and Hot Fixes
  2. MNT-453

when chain is alfrescoNtlm then ldap, external users cannot login

    Details

    • Escalated:
      Yes
    • ACT Numbers:

      41085

      Description

      related to ALF-12242 but not the same as there is not need to create a user manually

      How to reproduce?
      ==================
      1) create a plain vanilla alfresco 4.0 (linux tomcat mysql) with
      authentication chain:

      alfrescoNtlm:alfrescoNtlm,ldap:ldap

      2) as 'admin' create a site 'site1'

      ...Add External Users
      First Name:
      Last Name:
      Email:

      3) optionally, before pressing the invite button you can intercept the mail with
      tcpdump -s0 -w dump1.pcap port 25
      and decode it

      Result:
      ========
      Accept link works
      but login and password do not work

      Expected result:
      ==============
      Login and password work

        Attachments

        1. 864err.rar
          322 kB
        2. invite_shot.png
          invite_shot.png
          132 kB
        3. sample_invite.html
          6 kB

          Issue Links

            Activity

            Hide
            amadon Alex Madon added a comment -

            attaching sample invite: this issue basically is about:

            we send an email with 'you can log in into share here is your username and passwd' and when the person receiving the mail tries that login fails.

            Show
            amadon Alex Madon added a comment - attaching sample invite: this issue basically is about: we send an email with 'you can log in into share here is your username and passwd' and when the person receiving the mail tries that login fails.
            Hide
            hermelin Anne Hermelin (Inactive) added a comment -

            If you search the newly created user in the NodeBrowser with a lucene query "@usr\\:username:\"

            {userName}

            \"", you find out that the user is not enabled. Running a webscript that basically does
            userInTheUserStore.properties["usr:enabled"] = true;
            userInTheUserStore.save();
            Sorts out the problem.

            Show
            hermelin Anne Hermelin (Inactive) added a comment - If you search the newly created user in the NodeBrowser with a lucene query "@usr\\:username:\" {userName} \"", you find out that the user is not enabled. Running a webscript that basically does userInTheUserStore.properties ["usr:enabled"] = true; userInTheUserStore.save(); Sorts out the problem.
            Hide
            dward Dave Ward [X] (Inactive) added a comment -

            So the problem may be to do with user enabling

            Show
            dward Dave Ward [X] (Inactive) added a comment - So the problem may be to do with user enabling
            Hide
            alfrescoqa Alfresco QA Team added a comment -

            I've checked this issue on Alfresco Enterprise v.4.0.1 (build 864) Tomcat, PostgreSQL, Java 6 (all installer deployed) Client: Win7 SP1 x64, FF11.

            I'm able to login to Alfresco using credentials of any ldap user . But when I click the invitation URL from invitation letter my browser redirects me to the page with 500 - Internal error. Please refer to fail2.jpg. If I manually try to login to Alfresco Share and using My Task try to accept the invitation I get "Failure" notification (refer to fail1.jpg).

            alfresco-global, fail1.jpg, fail2.jpg and log file were attached to 864err.rar file.

            VadimZh

            Show
            alfrescoqa Alfresco QA Team added a comment - I've checked this issue on Alfresco Enterprise v.4.0.1 (build 864) Tomcat, PostgreSQL, Java 6 (all installer deployed) Client: Win7 SP1 x64, FF11. I'm able to login to Alfresco using credentials of any ldap user . But when I click the invitation URL from invitation letter my browser redirects me to the page with 500 - Internal error. Please refer to fail2.jpg. If I manually try to login to Alfresco Share and using My Task try to accept the invitation I get "Failure" notification (refer to fail1.jpg). alfresco-global, fail1.jpg, fail2.jpg and log file were attached to 864err.rar file. VadimZh
            Hide
            dward Dave Ward [X] (Inactive) added a comment -

            Corrected fix to ALF-12242

            Show
            dward Dave Ward [X] (Inactive) added a comment - Corrected fix to ALF-12242
            Hide
            alfrescoqa Alfresco QA Team added a comment -

            The issue is not reproduced on Enterprise - v4.0.1 (880), RHEL 5.5 x64bit, MySQL 5.5, mysql-connector-java-5.1.17-bin.jar, Tomcat 6.0.35, JDK 6 U27 X64, Alfresco+ OpenLDAP 2.4.23, Clustering Schema 2, FF 10.0, Windows 7
            TatianaK

            Show
            alfrescoqa Alfresco QA Team added a comment - The issue is not reproduced on Enterprise - v4.0.1 (880), RHEL 5.5 x64bit, MySQL 5.5, mysql-connector-java-5.1.17-bin.jar, Tomcat 6.0.35, JDK 6 U27 X64, Alfresco+ OpenLDAP 2.4.23, Clustering Schema 2, FF 10.0, Windows 7 TatianaK

              People

              • Assignee:
                closedbugs Closed Bugs
                Reporter:
                amadon Alex Madon
              • Votes:
                2 Vote for this issue
                Watchers:
                5 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Time Tracking

                  Estimated:
                  Original Estimate - 0 minutes
                  0m
                  Remaining:
                  Remaining Estimate - 0 minutes
                  0m
                  Logged:
                  Time Spent - 2 days, 7 hours, 30 minutes
                  2d 7h 30m