Service Packs and Hot Fixes
  1. Service Packs and Hot Fixes
  2. MNT-487

Internet Explorer hangs when using the object picker with a larger number of documents

    Details

    • Type: Service Pack Request Service Pack Request
    • Status: Closed Closed (View Workflow)
    • Priority: Blocker Blocker
    • Resolution: Fixed
    • Affects Version/s: 3.4.4
    • Fix Version/s: 3.4.9
    • Component/s: Share Application
    • Labels:
      None
    • Environment:
      Internet Explorer 8, and Internet Explorer 9 in diferent compatibility modes (IE7, IE8 and IE9), Also noticed in Firefox (but firefox behavior is much better).
    • Escalated:
      Yes
    • ACT Numbers:

      15024-34115

      Description

      [summary]
      Object picker in Alfresco Share causes the browser to freeze and take 100% of one CPU and can cause it to hang.

      [environment]
      Internet Explorer 8, and Internet Explorer 9 in diferent compatibility modes (IE7, IE8 and IE9), Also noticed in Firefox (but firefox behavior is much better).

      The issue is reproducible with an "out of the box" alfresco 3.4.4 at the 5th or 6th try (this process is degenerative and gets worse on every iteration) and only 200 documents in a folder but with 1000 documents it appears on the first of second try.

      The customer did it with a folder with 1000 documents, modifying the file:

      tomcat\webapps\share\WEB-INF\classes\alfresco\site-webscripts\org\alfresco\components\form\controls\association.ftl

      maxSearchResults: 1000

      [Reproduce problem]

      Create Agenda item:

      1. Create a new datalist of type agenda.
      2. Enter some random data
      3. Click Attachments -> Select
      4. Open a folder with many documents
      5. The List of documents is displays real slow in Internet Explorer (loaded after 10-20s)
      6. Select 2 or 3 documents as attachments
      7. Close the document picker
      8. Submit the new agenda item in the datalist

      Repeat the creation of the agenda items several times.

      Repeating this process few times and it gradually gets worse. The browser hangs and doesn't respond anymore. In some cases, this leads to an error that the item cannot be saved (probably a timeout).

      1. ALF10353-forIE.diff
        3 kB
        Alex Mukha
      1. Alf-10353.png
        75 kB
      2. EvAgenda.JPG
        67 kB
      3. screenshot.jpg
        187 kB
      4. screenshot2.jpg
        213 kB

        Issue Links

          Activity

          Alfresco QA Team added a comment -

          The issue is still exists on Alfresco Test v4.0.0 (build 684) Suse 11.1 x64, Tomcat, PostgreSQL, Java 6. Client: Win7x64+IE8 and WinXPx32 + IE7.

          -picker.inc.ftl was modified (maxSearchResults: 1000)
          -1000 files are uploaded to the folder TMP.
          -Agenda data list is created

          I've clicked "New item" button, added any 3 files from TMP folder and clicked "Submit".
          1. After 3-7 seconds I got a message from Windows Internet Explorer and clicked "Yes" button. After that I'm unable to attach any files to any data list item(see attachment screenshot).
          2.Clicked "No" button, New agenda item successfully created.

          We tested this issue when The customer did it with a folder with 100, 200, 300, 500, 800. It reproduce when folder contains more than 299 documents.

          David Draper added a comment -

          The new diff looks good to me - are QA going to commit this or would you like me to?

          Ravi Manthena added a comment -

          Use build 644 to test this issue

          Alfresco QA Team added a comment -

          The issue is reproduced on Alfresco Enterprise v3.4.9 (652).

          event-debug.js has not been changed.

          Thanks, DariaV

          Alfresco QA Team added a comment - - edited

          The issue isn't reproduced on Alfresco Enterprise v3.4.9 (653).

          Thanks, DariaV


            People

            • Assignee:
              Closed Bugs
              Reporter:
              Antonio Soler-Asenci
            • Votes:
              3 Vote for this issue
              Watchers:
              6 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Time Tracking

                Estimated:
                Original Estimate - 0 minutes
                0m
                Remaining:
                Remaining Estimate - 0 minutes
                0m
                Logged:
                Time Spent - 3 weeks, 2 days, 5 hours, 30 minutes
                3w 2d 5h 30m