Service Packs and Hot Fixes
  1. Service Packs and Hot Fixes
  2. MNT-5276

Alfresco within WebLogic requires to Edit a Web Application Module Scoped Role after each restart when working with stand-alone SOLR

    Details

    • Type: Bug Bug
    • Status: Closed Closed (View Workflow)
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: 4.0.1
    • Fix Version/s: 4.0.1
    • Component/s: Installer
    • Labels:
      None
    • Environment:
      Solaris 10, Oracle WebLogic Server 11g Rel1 (10.3.5), Oracle 11g v11.2.0.1, ojdbc6.jar, JDK 6 u27 x64

      Description

      Alfresco Enterprise 4.0.1 b802

      Issue is related to ALF-12783. Following to the Installing_Alfresco_4.0_on_JBoss.docx that are attached to related bug you have to perform the following steps after each weblogic start up or you will not have solr search working:

      22. Go to Deployments - alfresco - Modules - /alfresco - Security - Roles. Click on repoclient role with URL pattern "/".
      23. In Role Conditions section press Add Conditions button.
      24. Select User in Predicate List and click Next.
      25. Type Alfresco Repository Client in User Argument Name field and press Add button.
      26. Press Finish.
      27. Press Save.
      28. Now search using Solr subsystem should work.

      Alfresco deployed on properly configured weblogic be completely working after restart without addional steps in admin-console.

      1. Installing_Alfresco_4.0_on_WebLogic.docx
        20 kB
        Pavel Yurkevich
      2. weblogic-application.xml
        0.8 kB
        Pavel Yurkevich
      3. weblogic-application.xml.patch
        0.8 kB
        Pavel Yurkevich

        Activity

        Hide
        dward added a comment -

        Checked in the fix and ensured the correct doc was attached to ALF-12783.

        Show
        dward added a comment - Checked in the fix and ensured the correct doc was attached to ALF-12783.
        Hide
        oalexandrov added a comment -

        verfied with Alfresco Enterprise 4.0.1 b864

        Show
        oalexandrov added a comment - verfied with Alfresco Enterprise 4.0.1 b864

          People

          • Assignee:
            Closed Bugs
            Reporter:
            oalexandrov
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Time Tracking

              Estimated:
              Original Estimate - Not Specified
              Not Specified
              Remaining:
              Remaining Estimate - 0 minutes
              0m
              Logged:
              Time Spent - 1 day
              1d