Details

    • Type: Bug Bug
    • Status: Closed Closed (View Workflow)
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: 3.4.8, 4.0
    • Fix Version/s: 3.4.9
    • Component/s: Transformations
    • Labels:
      None

      Description

      Kevin: The attached .pdf crashes the pdf2swf process! Not sure why, but it does contain some interesting high-byte characters.

      1. PDF.pdf
        1.04 MB
        Erik Winlof

        Issue Links

          Activity

          dward added a comment -

          Best to check with bitrock-installed stack.

          Andrey Chernov added a comment - - edited

          We have two issues here:

          1) Provided PDF.pdf doesn't allow copying
          This is closly related to this issue:
          https://issues.alfresco.com/jira/browse/ALF-10451

          2) Error: Unknown character collection 'Adobe-Japan1' during attempt to convert pdf to swf using pdf2swf tool.

          To avoid point (1) to be able to continue investigation of point (2) I have used the
          first googled tool by systoolsgroup dot com.

          There are steps to force swftool properly convert unlocked PDF.pdf file:

          1) Install Alfresco Enterprise v3.4.8(568) schema 4208 using bitrock installer.
          2) Download Japanese support package from (Language Support Packages)
          http://www.foolabs.com/xpdf/download.html
          3) edit swf-transform-context.xml (please take no notice of hardcoded path, it's just for tests)

          <entry key=".*">

          • <value>$ {swf.exe} -T ${flashVersion} ${swf.encoder.params} ${source} -o ${target}</value>
            + <value>${swf.exe}

            -T $

            {flashVersion}

            $

            {swf.encoder.params}

            $

            {source}

            -o $

            {target}

            -s languagedir=D:/Alfresco/swftools/japanese</value>
            </entry>

          Content of D:/Alfresco/swftools/japanese
          CMap\
          add-to-xpdfrc
          Adobe-Japan1.cidToUnicode
          EUC-JP.unicodeMap
          ISO-2022-JP.unicodeMap
          README
          Shift-JIS.unicodeMap

          4) Restart Alfresco
          5) Enjoy.

          I bealive that we can include Language Support Packages provided by http://www.foolabs.com in to bitrock installer
          to avoid this and similar issues with other languages.

          AFAIK the issue is also reproducible on Ubuntu 10.04 LTS 64 bit but not sure about other *nix supported OS's seems also reprodicible.

          dward added a comment -

          Binaries provided by Bitrock

          Alfresco QA Team added a comment -

          Validated against Alfresco Enterprise v3.4.9 (678).

          Alfresco QA Team added a comment -

          Attached file is secured (refer https://issues.alfresco.com/jira/browse/ALF-10451).
          The issue was validated with unsecured file.


            People

            • Assignee:
              Closed Bugs
              Reporter:
              Erik Winlof
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Time Tracking

                Estimated:
                Original Estimate - 0 minutes
                0m
                Remaining:
                Remaining Estimate - 0 minutes
                0m
                Logged:
                Time Spent - 3 hours
                3h