Service Packs and Hot Fixes
  1. Service Packs and Hot Fixes
  2. MNT-5618

"500 - Internal Error" appears instead of "404 - Not Found" after accessing the documentation for the specified Web Script package

    Details

    • Type: Bug Bug
    • Status: Closed Closed (View Workflow)
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 4.0.1
    • Fix Version/s: 4.1.1
    • Component/s: Web Scripts and Surf
    • Labels:
      None
    • Environment:
      Alfresco Enterprise v4.0.1 (897)

      Description

      1. Go to http://host:port/alfresco/s/index/package/[package]/doc
      Any package

      Error appears:
      Web Script Status 500 - Internal Error

      The Web Script /alfresco/s/index/package/surfbug/doc has responded with a status of 500 - Internal Error.

      500 Description: An error inside the HTTP server which prevented it from fulfilling the request.

      Message: 03200042 Web Script documentation for package '/surfbug' not found

      Exception: org.springframework.extensions.webscripts.WebScriptException - 03200042 Web Script documentation for package '/surfbug' not found

      org.springframework.extensions.webscripts.bean.IndexPackageDoc.executeImpl(IndexPackageDoc.java:69)
      org.springframework.extensions.webscripts.DeclarativeWebScript.executeImpl(DeclarativeWebScript.java:235)
      org.springframework.extensions.webscripts.DeclarativeWebScript.execute(DeclarativeWebScript.java:64)
      org.alfresco.repo.web.scripts.RepositoryContainer$2.execute(RepositoryContainer.java:400)
      org.alfresco.repo.transaction.RetryingTransactionHelper.doInTransaction(RetryingTransactionHelper.java:388)
      org.alfresco.repo.web.scripts.RepositoryContainer.transactionedExecute(RepositoryContainer.java:462)
      org.alfresco.repo.web.scripts.RepositoryContainer.transactionedExecuteAs(RepositoryContainer.java:500)
      org.alfresco.repo.web.scripts.RepositoryContainer.executeScript(RepositoryContainer.java:316)
      org.springframework.extensions.webscripts.AbstractRuntime.executeScript(AbstractRuntime.java:372)
      org.springframework.extensions.webscripts.AbstractRuntime.executeScript(AbstractRuntime.java:209)
      org.springframework.extensions.webscripts.servlet.WebScriptServlet.service(WebScriptServlet.java:118)
      javax.servlet.http.HttpServlet.service(HttpServlet.java:717)
      org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:290)
      org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
      org.alfresco.web.app.servlet.GlobalLocalizationFilter.doFilter(GlobalLocalizationFilter.java:58)
      org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235)
      org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
      org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:233)
      org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:191)
      org.apache.catalina.authenticator.AuthenticatorBase.invoke(AuthenticatorBase.java:470)
      org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:127)
      org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:102)
      org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:109)
      org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:293)
      org.apache.coyote.http11.Http11AprProcessor.process(Http11AprProcessor.java:877)
      org.apache.coyote.http11.Http11AprProtocol$Http11ConnectionHandler.process(Http11AprProtocol.java:594)
      org.apache.tomcat.util.net.AprEndpoint$Worker.run(AprEndpoint.java:1675)
      java.lang.Thread.run(Thread.java:662)

      Server: Enterprise v4.0.1 (897) schema 5,028
      Time: Apr 20, 2012 5:34:55 PM

      Diagnostics: Inspect Web Script (org/springframework/extensions/webscripts/indexpackagedoc.get)

      There should be 404 error instead of 500.

      DariaV

        Activity

        Alfresco QA Team added a comment -

        The issue is successfully validated on Alfresco Enterprise 4.1.1 (build 151), Windows Server 2008 R2 x64, Tomcat, PostgreSQL, Java (all installer deployed)
        Client: WindowsXP, FF 14.0.1
        DariaMi


          People

          • Assignee:
            Closed Bugs
            Reporter:
            Alfresco QA Team
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: