Uploaded image for project: 'Service Packs and Hot Fixes'
  1. Service Packs and Hot Fixes
  2. MNT-5718

French: CMIS-QL - Range queries for date and datetime properties fail

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 4.0.1
    • Fix Version/s: 4.0.2
    • Component/s: CMIS
    • Labels:
      None
    • Environment:
      Alfresco Enterprise v4.0.1 build 830, Tomcat, PostgreSQL, Java (all installer deployed), SOLR

      Description

      Steps to reproduce:
      1. Install French Alfresco
      2. Connect to CMIS
      3. Type the query: "select * from cmis:folder WHERE cmis:creationDate > TIMESTAMP '2011-02-16T21:17:00.000+01:00' ". Press "Query" button
      Actual result: no folders found
      Exp. Result: folders with creation date earlier than 2011-02-16T21:17:00.000+01:00 should be found

      TatianaK

        Attachments

          Activity

          alfrescoqa Alfresco QA Team created issue -
          dhulley Derek Hulley made changes -
          Field Original Value New Value
          Status New [ 10001 ] Open [ 1 ]
          Fix Version/s 4.0.2 [ 11322 ]
          dhulley Derek Hulley made changes -
          Assignee Repo Team Unassigned [ repoteam ] Andrew Hind [ ahind ]
          ahind Andrew Hind added a comment - - edited

          I can not reproduce this against V4.0-BUG-FIX (V4.0.2) R 34985
          Please provide exact details on how to reproduce?
          I find all the folders in the test data.
          I am running with user.language=fr
          CMIS connects in French and works as expected for this query

          ahind Andrew Hind made changes -
          Status Open [ 1 ] Need Info [ 10002 ]
          Assignee Andrew Hind [ ahind ] Alfresco QA Team [ alfrescoqa ]
          alfrescoqa Alfresco QA Team added a comment -

          The issue is not reprodiced on Alfresco Enterprise v4.0.1 build 880, Tomcat, PostgreSQL, Java (all installer deployed), SOLR

          alfrescoqa Alfresco QA Team made changes -
          Status Need Info [ 10002 ] Open [ 1 ]
          alfrescoqa Alfresco QA Team made changes -
          Status Open [ 1 ] Closed [ 6 ]
          Assignee Alfresco QA Team [ alfrescoqa ] Closed Issues [ closedissues ]
          Resolution Fixed [ 1 ]
          adavis Alan Davis made changes -
          Status Closed [ 6 ] Editable Closed [ 10061 ]
          adavis Alan Davis made changes -
          Assignee Closed Issues [ closedissues ] Closed Bugs [ closedbugs ]
          adavis Alan Davis made changes -
          Project Alfresco [ 10281 ] Service Packs and Hot Fixes [ 11350 ]
          Key ALF-13407 MNT-5718
          Workflow Alfjira_II_PM [ 141073 ] Service Packs and Hot Fixes [ 177512 ]
          Fix Version/s 4.0.2 [ 12750 ]
          Fix Version/s 4.0.2 [ 11322 ]
          Status Transition Date 03/Apr/12 11:18 AM [ 2012-04-03T11:18+0100 ]
          Affects Version/s 4.0.1 [ 12749 ]
          Affects Version/s 4.0.1 [ 11020 ]
          Rank (Obsolete) 39270000000
          Component/s CMIS [ 12284 ]
          Component/s CMIS [ 10584 ]
          adavis Alan Davis made changes -
          Status Editable Closed [ 10061 ] Closed [ 6 ]
          adavis Alan Davis made changes -
          Workflow Service Packs and Hot Fixes [ 177512 ] Service Packs and Hot Fixes - rm EC [ 184821 ]
          adavis Alan Davis made changes -
          Workflow Service Packs and Hot Fixes - rm EC [ 184821 ] Service Packs and Hot Fixes [ 192112 ]
          Transition Time In Source Status Execution Times
          Derek Hulley made transition -
          New Open
          3m 27s 1
          Andrew Hind made transition -
          Open Need Info
          11d 1h 13m 1
          Alfresco QA Team made transition -
          Need Info Open
          20h 50m 1
          Alfresco QA Team made transition -
          Open Closed
          8s 1
          Alan Davis made transition -
          Closed Removed Status
          349d 6h 20m 1
          Alan Davis made transition -
          Removed Status Closed
          19h 34m 1

            People

            • Assignee:
              closedbugs Closed Bugs
              Reporter:
              alfrescoqa Alfresco QA Team
              My watchers:
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: