Details

    • Type: Bug Bug
    • Status: Closed Closed (View Workflow)
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: 4.0.1
    • Fix Version/s: 4.0.2
    • Component/s: WebDAV
    • Labels:
      None

      Description

      http://www.webdav.org/specs/rfc2518.html#rfc.section.8.4

      Alfresco WebDAV supports this for a file but currently throws HTTP 400 for a folder.

      Hence, for example, "sardine.exists(...)" returns unexpected false even if folder exists:

      http://code.google.com/p/sardine/issues/detail?id=48

        Activity

        Ravi Manthena added a comment -

        Assigned to Alfresco QA Team Re-Testing
        Use build 681 and SVN Revision number 32368 or later.

        Alfresco QA Team added a comment - - edited

        Please, provide more info how to test this issue.

        Alfresco QA Team added a comment -

        Sorry, a mistake was in previous comment. Could you please explain how I can test this issue?

        Alfresco QA Team added a comment -

        The issue is reproduced on Alfresco Enterprise v4.0.1 build 830, Tomcat, PostgreSQL, Java (all installer deployed), Win7x64, FF11.0 and RestClient 2.3.3.
        Head method for http://172.30.40.120:9080/alfresco/webdav/Folder5 returned HTTP/1.1 400 Bad Request, GET method for http://172.30.40.120:9080/alfresco/webdav/Folder5 returned HTTP/1.1 200 OK

        AlexPo

        Alfresco QA Team added a comment -

        Validated against Alfresco Enterprise v4.0.2(b911), Tomcat, Java, PostgreSQL (all installer deployed), Windows 7 SP1 x64, IE8, restclient-ui-2.3.3-jar-with-dependencies.jar.

        Head request return
        Status: HTTP/1.1 200 OK
        Server Apache-Coyote/1.1
        Set-Cookie JSESSIONID=0A74C3EAFB9417707698B824EFFBB23B; Path=/alfresco
        Content-Length 0
        Date Mon, 21 May 2012 12:47:28 GMT

        RomanCh


          People

          • Assignee:
            Closed Bugs
            Reporter:
            Jan Vonka
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Time Tracking

              Estimated:
              Original Estimate - Not Specified
              Not Specified
              Remaining:
              Remaining Estimate - 0 minutes
              0m
              Logged:
              Time Spent - 1 hour
              1h