Service Packs and Hot Fixes
  1. Service Packs and Hot Fixes
  2. MNT-5920

Alfresco Share: Recent Activities does not take localisation (and thus customization) into account,

    Details

      Description

      We've customized the list of activity types for Alfresco Share with our owns.

      This was done by defining a module customization following this blog post :
      http://blogs.alfresco.com/wp/ddraper/2011/08/03/customizing-alfresco-share-i18n-properties/

      Hence we added our custom types in the activity-list.get_en.properties file in a sourcePackageRoot, and everything output correctly in the Activity Dashlet.

      But the email summary "Recent activities" doesn't display the custom activities correctly, it seems that it's based directly on activity-list.get.properties like describe here:
      http://docs.alfresco.com/4.0/topic/com.alfresco.enterprise.doc/concepts/adminconsole-email-notification-list.html

      This email feed should take the customization/i18n files into account, and we should not have to override the file itself.

      1. dashlet OK.png
        20 kB
      2. mail KO.png
        10 kB

        Activity

        Patrick Lussan added a comment -

        the dashlet output fine, but not the email summary

        David Draper added a comment - - edited

        This is not actually a bug. The e-mails are generated by the Alfresco Server application (the "alfresco.war") and the Dashlets belong to the Share application ("share.war"). My understanding is that whilst it is true that the "activity-list.get.properties" localization file is used during the build process and will effect the e-mail output - changes to the file will only be reflected following a build.

        The extensibility function is only available as part of Share (not the Alfresco Server) and dynamically changes the behaviour of a WebScript. Therefore it could not possibly have any effect on a process that is running in a different application.

        I hope this clarifies why your approach will not have any effect on the e-mail content. To make these changes you will need to statically update the WebScript files through use of the "web-extension" path.

        Patrick Lussan added a comment -

        "whilst it is true that the "activity-list.get.properties" localization file is used during the build process and will effect the e-mail output - changes to the file will only be reflected following a build. "

        Can you please explain what build process you are describing? If I override the webscripts through 'web-extension' in my share amp, I need to run a particular build ant file?

        Patrick Lussan added a comment -

        also does it mean we can't localize those activity feed emails?

        Patrick Lussan added a comment -

        Ok I've found out. There are all copied in the alfresco/messages/ thanks

        Alfresco QA Team added a comment -

        Closed as not a bug


          People

          • Assignee:
            Closed Issues
            Reporter:
            Patrick Lussan
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: