Service Packs and Hot Fixes
  1. Service Packs and Hot Fixes
  2. MNT-6044

Mac OS X Lion 10.7.2: Editing a document via CIFS and TextEdit removes versionable aspect from this file

    Details

    • Type: Bug Bug
    • Status: Closed Closed (View Workflow)
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: 3.4.8
    • Fix Version/s: 4.0.2
    • Component/s: CIFS
    • Labels:
      None
    • Environment:
      Alfresco Enterprise v3.4.8 (build 592) Tomcat, PostgreSQL, Java 6 (all installer deployed)
      Client: Mac OS X Lion 10.7.2

      Description

      Steps to reproduce:

      • upload any document and add a versionable aspect to this document using Alfresco Share;
      • login to Alfresco via CIFS via Finder (smb://host/alfresco);
      • edit this document using TextEdit and save it;
      • login to Alfresco Share, find this document and click "Manage Aspects" in "more" menu;

      Actual result: versionable aspect is absent.

      Expected result: versionable aspect is still present.

      VadimZh

      1. ScenarioCopyContentShuffle.java
        3 kB
        Vasily Olhin
      2. ScenarioCopyContentShuffleInstance.java
        5 kB
        Vasily Olhin
      3. text_capture.pcap
        77 kB
        Vasily Olhin
      4. word_capture.pcap
        239 kB
        Vasily Olhin
      1. temp_folder_appeared_in_repository.gif
        63 kB

        Issue Links

          Activity

          Alfresco QA Team added a comment -

          The issue was reproduced on Alfresco Enterprise v.4.0.1 (build 864) Tomcat, PostgreSQL, Java 6 (all installer deployed), RHEL 5.5 64 bit. Client: Mac OS X Lion 10.7.2, TextEdit
          VadimZh

          Mark Rogers added a comment - - edited

          duplicate comment

          Mark Rogers added a comment -

          I've got the scenario for the locked delete shuffle wrong.

          It looks like the pattern is:

          1) create temp directory
          2) create temp resource fork file and write content
          3) create temp file and write content.
          4) delete target file
          5) move temp file to target
          6) delete resource fork
          7) move temp resource fork to destination.
          8) delete temp directory.

          The example I have has studied has the following paths:
          temp file : \.TemporaryItems\folders.502\TemporaryItems(A Document Being Saved By TextEdit)\TextEditFileA .txt
          temp resource fork : \.TemporaryItems\folders.502\TemporaryItems(A Document Being Saved By TextEdit)\._TextEditFileA .txt
          target file: \simple\TextEditFileA .txt
          resource fork: \simple\._TextEditFileA .txt

          Mark Rogers added a comment -

          A new filter added and unit test changed. r35475 on V4.0-UG-FIX.

          Please note:
          a) the text edit filter is only configured to work for files with names matching the *.txt pattern. We can relax that pattern if needed once we become confident of the new filter.
          b) temporary files are incorrectly hidden after being edited by text edit. That should be fixed when r35375 is merged.

          vjeynov added a comment -

          Successfully validated against Alfresco v4.0.2 build 911, Jboss 5.1.1, Oracle 10g, Java 6 (all installer deployed) Client:Mac OSX 10.7.2


            People

            • Assignee:
              Closed Bugs
              Reporter:
              Alfresco QA Team
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Time Tracking

                Estimated:
                Original Estimate - 0 minutes
                0m
                Remaining:
                Remaining Estimate - 0 minutes
                0m
                Logged:
                Time Spent - 1 week, 4 days, 3 hours
                1w 4d 3h