Service Packs and Hot Fixes
  1. Service Packs and Hot Fixes
  2. MNT-6060

CMIS: Error occurs trying to delete a multilingual document

    Details

    • Type: Bug Bug
    • Status: Closed Closed (View Workflow)
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 4.0.1
    • Fix Version/s: 4.1.1
    • Component/s: CMIS
    • Labels:
      None
    • Environment:
      Alfresco Enterprise v4.0.1 (830)

      Description

      1. Open Alfresco Explorer;
      2. Upload any content;
      3. Make the content multilingual;
      4. Connect to CMIS workbench;
      5. Try to delete ml document;

      Error occurs (see att. screenshot).

      Log says:
      2012-03-19 12:01:21,530 ERROR [node.integrity.IntegrityChecker] [[ACTIVE] ExecuteThread: '11' for queue: 'weblogic.kernel.Default (self-tuning)'] Found 1 integrity violations:
      The association child multiplicity has been violated:
      Source Node: workspace://SpacesStore/3f5453af-b598-4d64-8b94-62fc50dfe8bc
      Association: Association[ class=ClassDef[name=

      {http://www.alfresco.org/model/content/1.0}

      mlContainer], name=

      {http://www.alfresco.org/model/content/1.0}

      mlChild, target class=

      {http://www.alfresco.org/model/content/1.0}

      mlDocument, source role=null, target role=null]
      Required child Multiplicity: 1..*
      Actual child Multiplicity: 0

      The issue is reproduced while user connected via two bindings atompub and webservices.

      DariaV

        Issue Links

          Activity

          Hide
          Steven Glover added a comment -

          The MLContainer returned by MultiLingualContentServiceImpl.getMLContainer seems to be unexpectedly null (tested on HEAD).

          Show
          Steven Glover added a comment - The MLContainer returned by MultiLingualContentServiceImpl.getMLContainer seems to be unexpectedly null (tested on HEAD).
          Hide
          Alfresco QA Team added a comment -

          Successfully validated on Alfresco Enterprise v4.1.1 (b134), Tomcat, PostgreeSQL, Java (all installer deployed), Win7x64, ff 14.0.1
          OlgaPal

          Show
          Alfresco QA Team added a comment - Successfully validated on Alfresco Enterprise v4.1.1 (b134), Tomcat, PostgreeSQL, Java (all installer deployed), Win7x64, ff 14.0.1 OlgaPal

            People

            • Assignee:
              Closed Bugs
              Reporter:
              Alfresco QA Team
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: