Service Packs and Hot Fixes
  1. Service Packs and Hot Fixes
  2. MNT-6066

Transformation Server has problems with 9k.docx but not the same file when called 9k-1.docx

    Details

    • Type: Bug Bug
    • Status: Closed Closed (View Workflow)
    • Priority: Blocker Blocker
    • Resolution: Fixed
    • Affects Version/s: 3.4.6, 3.4.7, 3.4.8, 4.0.1, 4.0
    • Fix Version/s: 4.1.2
    • Component/s: Transformation Server
    • Labels:
      None
    • Environment:
      transformation-client-1.0.0-RC3-3.4.amp matching 3.4.8 RC > #618

      Description

      >> I would like to suggest this is a BLOCKER for the Transformation Server rather than 3.4.8 <<

      >> Original Subject: Transformation Server does not support docx ->swf even though its config says it does. <<
      >> But now looks like something else, as a second upload of the same file works. See comment made 02-Mar-12 02:27 PM <<

      It appears that the Transformation Server CLIENT configuration indicates that it can support transformation that are not possible on the server.
      For example docx to swf. See attached TS_RC3-docx-swf.html which was extracted from the attched alfresco.log. As a result the transformation fails.

      Also extracted from the log is supported.log which indicates which transformations 'appear' to be possible.

      Used a development version of 3.4.8 that includes:

      • The Alfresco side changes for ALF-13030 and ALF-13041
      • The Westernacher side changes for ALF-13041 ( transformation-client-1.0.0-RC3-3.4.amp )
      • Alfresco Global Properties set (used by code for ALF-13041) that force the Transformation Server to be used rather than Office or JOD transformers.

      transformer.OpenOffice.time=3600000
      transformer.complex.OpenOffice.Image.time=3600000
      transformer.complex.OpenOffice.Pdf2swf.time=3600000
      transformer.complex.OpenOffice.PdfBox.time=3600000

      transformer.JodConverter.time=3600000
      transformer.complex.JodConverter.Image.time=3600000
      transformer.complex.JodConverter.Pdf2swf.time=3600000
      transformer.complex.JodConverter.PdfBox.time=3600000

      1. 9k.docx
        12 kB
        Alan Davis
      2. alfresco.log
        399 kB
        Alan Davis
      3. supported.log
        40 kB
        Alan Davis
      4. TS_RC3-docx-pdf.html
        2 kB
        Alan Davis
      5. TS_RC3-docx-swf.html
        6 kB
        Alan Davis

        Activity

        Alan Davis added a comment -

        The original issue may be reproduced by:

        • Install Alfresco WITHOUT the Transformation server AMP
        • Upload a docx to Share DON'T preview it.
        • Install the Transformation server AMP
        • Preview the docx

        If a docx is uploaded on a system that has the Transformation server AMP installed, another error (NPE) takes place on transformation from docx to pdf (see attached TS_RC3-docx-pdf which is again is some HTML extracted from the log). As a result the thumbnail is not created.

        The original docx to swf issue may then also be reproduced by previewing the document

        Alan Davis added a comment -

        Not sure what is going on any longer, as I don't have any errors if I upload the file file again. In this case the file is given a modified name '9k-1.docx' rather than '9k.docx'.

        That would indicate something other than supported mimetype conversions. I do see the '9k-1.docx' in the admin console but not the '9k.docx'.

        Have just attached 9k.docx.

        Andrew Hunt added a comment -

        Fixed in 3.4.9 (1.0.1 amp)

        Alfresco QA Team added a comment -

        The issue is reproduced on Alfresco Enterprise 3.4.11 (build 935), Windows Server 2008 x64, Tomcat, PostgreSQL, Java (all installer deployed), FF 16.0.2
        alfresco-transformationserver-repo-1.0.1.amp, alfresco-transformationserver-repo-1.0.2.amp
        Transformation Server v 1.1.0

        DariaMi

        Andrew Hunt added a comment -

        Fixed in RC5

        Alfresco QA Team added a comment -

        The issue is not reproduced on Alfresco Enterprise v.4.1.2 (b 334)
        Clustered RHEL 5.5 x64bit MySQL 5.5 mysql-connector-java-5.1.17-bin.jar Tomcat 6.0.35
        JDK 6 U33 X64 Alfresco+ OpenLDAP 2.4.23
        Schema 2* FF 16.0.1
        Transformation server 1.3.1 (buld0003)

        OlgaPal


          People

          • Assignee:
            Closed Bugs
            Reporter:
            Alan Davis
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: