Service Packs and Hot Fixes
  1. Service Packs and Hot Fixes
  2. MNT-6110

It's impossible to manage aspects via WebServices.

    Details

    • Type: Bug Bug
    • Status: Closed Closed (View Workflow)
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: 4.0.1
    • Fix Version/s: 4.0.2
    • Component/s: CMIS
    • Labels:
      None
    • Environment:
    • Testcase ID:

      swift-692

      Show
      swift-692

      Description

      Steps to reproduce:
      1) Open CMIS Workbench;
      2) Choose "Expert" tab --> Alfresco 4 Web Services;
      3) Put valid <host>:<port>;
      4) Add:
      cmis.workbench.folder.includeAcls=false
      cmis.workbench.object.includeAcls=false
      cmis.workbench.version.includeAcls=false
      org.apache.chemistry.opencmis.objectfactory.classname=org.alfresco.cmis.client.impl.AlfrescoObjectFactoryImpl

      5) Try to login.

      Actual result: an error occurs (see att.)

      NOTE: AtomPub connection is blocked on WebSphere by ALF-12742. I have tested on locally Alfresco from installer (build 802): it works OK using AtomPub connection, but the same error occurs via Web Services.

      1. ALF13088.diff
        0.7 kB
        Alex Mukha
      1. cmis - ws.png
        39 kB

        Issue Links

          Activity

          dward added a comment -

          Is this Websphere specific?

          dward added a comment - - edited

          The endorsed xalan jar is an installation requirement for some WCM Web Forms functionality. It doesn't work with xsltc.

          Alfresco QA Team added a comment -

          The issue is not reproduced only on WEBLOGIC, on the rest environments the described problem occurs
          TatianaK

          dward added a comment -

          The two examples given at

          http://groups.google.com/group/alfresco-opencmis-extension/browse_thread/thread/f9d9152691e5a04f

          are equivalent. They just use different ways of serializing the same namespaced XML.

          I think the problem may lie in the way that OpenCMIS deserializes extension elements. It strips the namespace from all attributes, loading their local name into a single map. That means xmlns:propertyDefinitionId and propertyDefinitionId:propertyDefinitionId may be considered to be the same attribute.

          Please try applying the attached patch to

          https://svn.apache.org/repos/asf/chemistry/opencmis/trunk

          If it works, we'll contribute the patch to OpenCMIS.

          dward added a comment -
          dward added a comment -

          Upgraded to OpenCMIS 0.7.0

          Alfresco QA Team added a comment -

          Env: Windows 7 SP1 x64 Alfresco Enterprise v4.0.2(b911) Tomcat, Java, PostreSQL (all installer deployed). OpenCMIS 0.7.0 Workbench

          No errors are appeared on log in. Managing aspects via webservices passes without errors.

          RomanCh


            People

            • Assignee:
              Closed Bugs
              Reporter:
              prudenya
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Time Tracking

                Estimated:
                Original Estimate - 0 minutes
                0m
                Remaining:
                Remaining Estimate - 0 minutes
                0m
                Logged:
                Time Spent - 3 days, 1 hour
                3d 1h