Service Packs and Hot Fixes
  1. Service Packs and Hot Fixes
  2. MNT-6235

"Could not load properties"/InvalidQNameException while trying to open/edit rule in Share

    Details

    • Type: Bug Bug
    • Status: Closed Closed (View Workflow)
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: 4.0
    • Fix Version/s: 4.0.2
    • Component/s: Share Application
    • Labels:
      None
    • Environment:
      Ubuntu Linux 2011.04
      Alfresco Enterprise v4.0.0 (800) schema 5025
      Spring Surf and Spring WebScripts - v1.0.0 (Release 968)

      Description

      Steps on an out-of-the-box Alfresco 4.0 Enterprise:
      1) Start Alfresco
      2) Go to Share
      3) Log in as admin
      4) Open repository browser
      5) Browse to Data dictionary
      6) Click on the "Manage rules" action for "Models" or "Workflow Definitions"
      7) Exception below appears in alfresco.log :

      17:06:52,220 ERROR [org.springframework.extensions.webscripts.AbstractRuntime] Exception from executeScript - redirecting to status template error: 03160004 Wrapped Exception (with status template): A QName must consist of a local name
      org.springframework.extensions.webscripts.WebScriptException: 03160004 Wrapped Exception (with status template): A QName must consist of a local name
      at org.springframework.extensions.webscripts.AbstractWebScript.createStatusException(AbstractWebScript.java:970)
      at org.springframework.extensions.webscripts.DeclarativeWebScript.execute(DeclarativeWebScript.java:171)
      at org.alfresco.repo.web.scripts.RepositoryContainer$2.execute(RepositoryContainer.java:393)
      at org.alfresco.repo.transaction.RetryingTransactionHelper.doInTransaction(RetryingTransactionHelper.java:388)
      at org.alfresco.repo.web.scripts.RepositoryContainer.transactionedExecute(RepositoryContainer.java:462)
      at org.alfresco.repo.web.scripts.RepositoryContainer.transactionedExecuteAs(RepositoryContainer.java:500)
      at org.alfresco.repo.web.scripts.RepositoryContainer.executeScript(RepositoryContainer.java:316)
      at org.springframework.extensions.webscripts.AbstractRuntime.executeScript(AbstractRuntime.java:372)
      at org.springframework.extensions.webscripts.AbstractRuntime.executeScript(AbstractRuntime.java:209)
      at org.springframework.extensions.webscripts.servlet.WebScriptServlet.service(WebScriptServlet.java:118)
      at javax.servlet.http.HttpServlet.service(HttpServlet.java:717)
      at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:290)
      at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
      at org.alfresco.web.app.servlet.GlobalLocalizationFilter.doFilter(GlobalLocalizationFilter.java:58)
      at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235)
      at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
      at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:233)
      at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:191)
      at org.apache.catalina.authenticator.AuthenticatorBase.invoke(AuthenticatorBase.java:470)
      at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:127)
      at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:102)
      at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:109)
      at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:298)
      at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:857)
      at org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.process(Http11Protocol.java:588)
      at org.apache.tomcat.util.net.JIoEndpoint$Worker.run(JIoEndpoint.java:489)
      at java.lang.Thread.run(Thread.java:662)
      Caused by: org.alfresco.service.namespace.InvalidQNameException: A QName must consist of a local name
      at org.alfresco.service.namespace.QName.createQName(QName.java:84)
      at org.alfresco.service.namespace.QName.createQName(QName.java:121)
      at org.alfresco.repo.web.scripts.dictionary.PropertiesGet.executeImpl(PropertiesGet.java:83)
      at org.springframework.extensions.webscripts.DeclarativeWebScript.execute(DeclarativeWebScript.java:64)
      ... 25 more

      The error is also visible on the UI, see attached screenshot.

      It is similar closed issue ALF-10960, which I don't have the rights to reopen.

        Activity

        Nicolas Raoul added a comment -

        Screenshot

        dward added a comment -

        QA: please retest.

        If confirmed fixed, fix will be available in Nightly builds.

        Alfresco QA Team added a comment -

        The issue is reproduced on Alfresco 4.0.1 (897)
        TatianaK

        Erik Winlof added a comment -

        Fixed on DEV/V4.0-BUG-FIX revision 36248.

        Cheers for the investigation, there is now a null check however around a greater part of the loop than suggested so no unnecessary iteration is done.

        Alfresco QA Team added a comment -

        The issue is not reproduced on Alfresco Enterprise v4.0.2 build 904, Tomcat, PostgreSQL, Java (all installer deployed), Win7x64, FF11.0
        TatianaK


          People

          • Assignee:
            Closed Bugs
            Reporter:
            Nicolas Raoul
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Time Tracking

              Estimated:
              Original Estimate - Not Specified
              Not Specified
              Remaining:
              Remaining Estimate - 0 minutes
              0m
              Logged:
              Time Spent - 4 hours
              4h