Details

    • Type: Bug Bug
    • Status: Closed Closed (View Workflow)
    • Priority: Critical Critical
    • Resolution: Not a bug
    • Affects Version/s: 4.0
    • Fix Version/s: None
    • Component/s: CMIS
    • Labels:
      None
    • Environment:
      Alfresco Enterprise - v4.0.0 (c 643), Windows Server 2008 R2 x64, Oracle 10g v10.2.0.4, oracle.jdbc.OracleDriver ojdbc14.jar, JBoss 5.1.0.EAP, JDK 6 u22 x64, NTLM, IE9, Windows 7.
    • Testcase ID:

      swift-674

      Show
      swift-674

      Description

      Steps to reproduce:
      1. Log in CMIS;
      2. Create 15 "test" files (test1, test2, test3, ... test15);
      3. Press "Query" button;
      4. Run the following script:

      String query = "SELECT * FROM cmis:document WHERE cmis:name LIKE 'test%'";
      ItemIterable<QueryResult> q = session.query(query, false);

      // Did it work?
      System.out.println("***results from query " + query);

      int i = 1;
      for (QueryResult qr : q)

      { System.out.println("--------------------------------------------\n" + i + " , " + qr.getPropertyByQueryName("cmis:objectTypeId").getFirstValue() + " , " + qr.getPropertyByQueryName("cmis:name").getFirstValue() + " , " + qr.getPropertyByQueryName("cmis:createdBy").getFirstValue() + " , " + qr.getPropertyByQueryName("cmis:objectId").getFirstValue() + " , " + qr.getPropertyByQueryName("cmis:contentStreamFileName").getFirstValue() + " , " + qr.getPropertyByQueryName("cmis:contentStreamMimeType").getFirstValue() + " , " + qr.getPropertyByQueryName("cmis:contentStreamLength").getFirstValue()); i++; }

      Actual result: an error occurs. (see attached screenshot)

      Expected result: the result set should be returned.

      NOTE: It seems to be regression because it worked correctly with Alfresco 4.0.0 build 361 or 409 where index subsystems was lucene.
      NOTE2: No errors are in the logs.

      PavelRu

        Activity

        Steven Glover added a comment -

        I cannot reproduce on latest HEAD (tried both lucene and Solr search).

        Alfresco QA Team added a comment -

        The issue is reproduced on Alfresco Enterprise v4.0.0 (791) using chemistry-opencmis-workbench-0.7.0-SNAPSHOT-full.

        Derek Hulley added a comment -

        Was not reproducible, but QA are still seeing it. Requires further investigation in case it's environmental.

        Steven Glover added a comment -

        I'm unable to reproduce. Could you check for environmental issues e.g. is Solr accessible?

        Steven Glover added a comment -

        Nicely spotted Viachaslau, thanks.

        Ravi Manthena added a comment -

        Use build 13 to test this issue.

        Alfresco QA Team added a comment -

        Closed as not a bug


          People

          • Assignee:
            Closed Issues
            Reporter:
            Alfresco QA Team
          • Votes:
            0 Vote for this issue
            Watchers:
            4 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Time Tracking

              Estimated:
              Original Estimate - Not Specified
              Not Specified
              Remaining:
              Remaining Estimate - 0 minutes
              0m
              Logged:
              Time Spent - 6 hours
              6h