Uploaded image for project: 'Service Packs and Hot Fixes'
  1. Service Packs and Hot Fixes
  2. MNT-8295

CLONE -"Set Values and Add" button for Rules does not properly handle Unicode character translations

    Details

    • Bug Priority:
      Category 3

      Description

      Set these properties in messages/webclient_ja_JP.properties and log into Alfresco with the ja_JP locale:

      click_set_and_add=\u30af\u30ea\u30c3\u30af\u3057\u3066\u5024\u3092\u8a2d\u5b9a\u3057\u30ea\u30b9\u30c8\u306b\u8ffd\u52a0
      set_and_add_button=\u5024\u3092\u8a2d\u5b9a\u3057\u3066\u8ffd\u52a0

      Those escaped characters appear to be normal Japanese characters as verified by placing into a JTextField.

      METHOD:
      1. Logon as Administrator.
      2. Click "Company Home".
      3. Click "More Actions->Manage Content Rules".
      4. Click "Create Rule" button.
      5. Selete an item from "Selete Condition" dropdown list.

      Garbage is displayed in the button text as shown in the attached file.

        Attachments

          Issue Links

            Structure

              Activity

                People

                • Assignee:
                  closedbugs Closed Bugs
                  Reporter:
                  jcohorn jcohorn
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  1 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved:

                    Structure Helper Panel