Service Packs and Hot Fixes
  1. Service Packs and Hot Fixes
  2. MNT-8330

Clickable link in Preview does not move to the target page.

    Details

    • Type: Bug Bug
    • Status: Closed Closed (View Workflow)
    • Priority: Critical Critical
    • Resolution: Won't Fix
    • Affects Version/s: 3.4.1
    • Fix Version/s: None
    • Component/s: Transformations
    • Labels:
      None
    • Environment:
      ImageMagick 6.5.1-0 2010-07-01 Q16, ImageMagick 6.6.3-1 2010-07-05 Q16
      OpenOffice: 3.2.0 (OOO320m12 (Build 9483))

      Description

      Steps to reproduce it.

      1. Login to Share.
      2. Upload the attached document to DocumentLibrary in Share.
      3. Go to the document detail page.
      4. Click the clickable Link on table of contents in the preview.

      [Actual Behaviour]
      The link is clickable, but it does not move to the target page. The Internal page Link does not work.

      [Expected Behaviour]
      The link is clickable, and it should move to the target page.

      [Additional Information]
      I converted the document into pdf using Alfresco's transform function. I confirmed that the internal link of the table of contents, correctly move to the target page, but when upload the pdf file into document library, the clickable link does not go to the target page,

      1. Analyse.odt
        71 kB
        Kazuyuki Kono
      2. Analyse.pdf
        140 kB
        Kazuyuki Kono

        Activity

        Valery Shikunets added a comment - - edited

        Issue happens when the odt-document has been transformed into pdf using Alfresco's transform function.
        With other pdf-documents the page with table of contents does not disappear.
        Transformation occurs through JODConverter. Transformation is performed in org.artofsolving.jodconverter.OfficeDocumentConverter class

        Valery Shikunets added a comment - - edited

        The issue is connected to table of contents of the transformed pdf file. When the file is displayed in the swf viewer, after the click on the table of contents item, the current page is replaced by the page linked in table of contents. And it is not possible to scroll up to see table of contents again. This happens only with pdf-files that were converted from odt-format in pdf-format by JodConverter. With other pdf files all works correct in the meaning that table of contents is available after redirect from.

        I've tried to generate pdf directly from OpenOffice.org Writer from the document with a table of contents. The links are functional in generated pdf (looked in Abobe Reader). But when the pdf is converted to swf, those kinks didn't work as expected. They redirect to the page but it is not possible to scroll up to the table of contents again.

        Tried even with following conversion options (swf-transform-context.xml in bean with id="transformer.worker.Pdf2swf" in property whith name="commandMap):

        $

        {swf.exe}

        -T$

        {flashVersion}

        $

        {swf.encoder.params}

        -s internallinkfunction=handleInternalLink $

        {source}

        -o $

        {target}

        Result is unsuccessful.

        Andrew Hunt added a comment -

        Polymorph uses pdf2swf as well.

        Closing this as Won't Fix, as per above comments

        Alan Davis added a comment -

        Resolution when issue was in ALF was Won't Fix

        Alfresco QA Team added a comment -

        Close as Won't Fix according to Alan Davis resolution.
        SvetlanaVi


          People

          • Assignee:
            Closed Issues
            Reporter:
            Kazuyuki Kono
          • Votes:
            1 Vote for this issue
            Watchers:
            4 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: