Uploaded image for project: 'Repository'
  1. Repository
  2. REPO-1090

REGRESS: Smart Folders - Nodes API list children returns empty results

    Details

    • Bug Priority:
      Category 1
    • Work Funnel:
      Feature
    • Sprint:
      Zulu Sprint 4
    • Story Points:
      3

      Description

      Using 5.2.a-EA community installer, virtual folders are not showing up when listing children on a smart folder.

      Steps to reproduce:

      • Install 5.2.a-EA community ( Community 201606 EA )
      • Enable Smart Folders - add "smart.folders.enabled=true" to alfresco-global.properites
      • As admin, create a folder (let's say under the "Shared" folder)
      • Apply aspect "System Smart Folder (smf:systemConfigSmartFolder)
      • Edit properties (All Properties) and select "Smart Folder Template" - use stock/ootb smart folder configuration ("smartFoldersExample.json")
      • Login as a test user, and browse folder via Share (or WebDAV) to confirm smart folder works
      • Try listing children via nodes/{nodeId}/children - no results are returned

      Questions

      Implementation
      Was working at the beginning of the "a new hope" bundle

        Attachments

          Issue Links

            Structure

              Activity

                People

                • Assignee:
                  Unassigned
                  Reporter:
                  ohejlskov Ole Hejlskov
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  3 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved:

                    Structure Helper Panel