Details

    • Work Funnel:
      Architecture
    • Sprint:
      Repository Sprint 24, Repo Libraries Sprint 25
    • Story Points:
      8
    • Work Funnel End:
      2018-03
    • Template:

      Description

      The version of Quartz Scheduler we are using currently is based 1.8.3, which is 6 years old.
      However, we have patched it, so we cannot upgrade it easily.

      The patch was committed in r31401 to fix ALF-2980 (now named MNT-2191)
      It is simply a small addition to the shutdown hook – see the full diff here https://svn.alfresco.com/repos/alfresco-open-mirror/alfresco/COMMUNITYTAGS/V5.0.d/root/projects/3rd-party/src/quartz-1.8.3-patched.diff

      I believe this was integrated into Quartz in 2.1.0 - see this commit in Quartz source code https://fisheye.terracotta.org/changelog/Quartz?cs=1596

      So, I think we can safely upgrade Quartz to the latest version, after making sure MNT-2191 doesn't reproduce.

        Attachments

          Structure

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                slanglois Samuel Langlois [X] (Inactive)
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Structure Helper Panel