Records Management
  1. Records Management
  2. RM-355

Record Management: Incorrect calendar year displayed

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Critical Critical
    • Resolution: Cannot Reproduce
    • Affects Version/s: 2.0
    • Fix Version/s: 2.0
    • Component/s: UI
    • Security Level: external (External user)
    • Labels:
      None
    • Environment:
      OS: RHEL
      App Server: JBoss
      Database: Oracle
    • Resource:
      External
    • Escalation level:
      Reviewed

      Description

      Incorrect calendar year displayed on multiple RM page

      Edit Disposition Date page: -

      1. Create a RM site, create one Series, one Category, and one Folder.
      2. Create a disposition schedule on the Category. Set to Cutoff after 1 day.
      3. Go to records folder and select Edit Disposition Date from the menu.
      Actual: you will see calendar year listed as'112'
      Expected: Calendar year listed as "12' or '2012'

      Declared a file record: -

      4. Navigate to Series1>Category1>Folder1, add/upload a file by clicking File button, select "Electronic" , select and upload a .pdf file.
      5. Notice this file record is currently Undeclared Record and display correct calendar year Eg. Modified on: Tue 1 May 2012 11:44:27
      6. Click Edit Metadata for the file record, fill in all required fields that is empty, specifically the Record originator, Originating Organization, Publication Date. Click Save.
      6. Now, Mouse over to the record item, you should see the "Declare as Record" link, click "Declare as Record" link.
      Actual: You will see "Date Filed: Sun 1 May 112 04:26:35"
      Expected : See "Date Filed: Sun 1 May 12 04:26:35"

        Activity

        Hide
        Seng Liaw added a comment -

        Correction to the JIRA description: Please also note that the day of the week incorrect. Today is Tuesday, May 1, 2012 but Alfresco is reporting Sunday, May 1, 112. The expected value should be "Date Filed: Tue 1 May 12 04:26:35" in your bug report. It's also incorrect in the calendar control. Suspecting it got the wrong file time as well.

        Show
        Seng Liaw added a comment - Correction to the JIRA description: Please also note that the day of the week incorrect. Today is Tuesday, May 1, 2012 but Alfresco is reporting Sunday, May 1, 112. The expected value should be "Date Filed: Tue 1 May 12 04:26:35" in your bug report. It's also incorrect in the calendar control. Suspecting it got the wrong file time as well.
        Hide
        Roy Wetherall added a comment -

        Could we please investigate if this is a common issue with RM2 running on 4.0.1

        Show
        Roy Wetherall added a comment - Could we please investigate if this is a common issue with RM2 running on 4.0.1
        Hide
        Roy Wetherall added a comment -

        Edit Disposition Date should be working ok now ... would you mind taking another look at this please

        Show
        Roy Wetherall added a comment - Edit Disposition Date should be working ok now ... would you mind taking another look at this please
        Hide
        David Draper added a comment -

        Screeenshot showing correct file date

        Show
        David Draper added a comment - Screeenshot showing correct file date
        Hide
        David Draper added a comment -

        Screenshot showing correct calendar

        Show
        David Draper added a comment - Screenshot showing correct calendar
        Hide
        David Draper added a comment -

        I'm not able to reproduce this issue (please see attached screenshots). Please confirm if this is a browser specific problem.

        Show
        David Draper added a comment - I'm not able to reproduce this issue (please see attached screenshots). Please confirm if this is a browser specific problem.
        Hide
        Alfresco QA Team added a comment -

        For retest on build 100

        Show
        Alfresco QA Team added a comment - For retest on build 100
        Hide
        Alfresco QA Team added a comment -

        The issue is not reproduced for RM 2.0.100, Alfresco Enterprise v4.0.2 (966), RHEL 5.5 x64bit, MySQL 5.5, mysql-connector-java-5.1.17-bin.jar, Tomcat 6.0.35, JDK 6 U31 X64, Alfresco+ OpenLDAP 2.4.23, FF10.0т (latest), Windows 7.
        The issue was raised for Alfresco Enterprise v3.4.10 (b701) - RM-409.
        DariaV

        Show
        Alfresco QA Team added a comment - The issue is not reproduced for RM 2.0.100, Alfresco Enterprise v4.0.2 (966), RHEL 5.5 x64bit, MySQL 5.5, mysql-connector-java-5.1.17-bin.jar, Tomcat 6.0.35, JDK 6 U31 X64, Alfresco+ OpenLDAP 2.4.23, FF10.0т (latest), Windows 7. The issue was raised for Alfresco Enterprise v3.4.10 (b701) - RM-409 . DariaV

          People

          • Assignee:
            Closed Issues
            Reporter:
            Seng Liaw
          • Votes:
            0 Vote for this issue
            Watchers:
            5 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:
              Date of First Response: